How to make Intel Management Engine version valid?

In Gnome 43 settings, the “Device security” tab shows I am at Level 0 since my “Intel Management Engine Version” is “Not Valid”. I have a HP laptop but HP didn’t provide any updates on Linux. I also checked the Intel website and there are only graphics driver available.

May I know anywhere else I can find a driver or update, or other method to make the IME version valid?

Model: HP Pavilion Power Laptop 15-cb044tx
CPU: Intel Core i7 7700HQ

Thank you

Welcome to ask.fedora @adrianl40

Please have a look to the following question/answer:

You might have to search also in the log files/journal to get a hint what might is missing.

Please give more info about your system as inxi -Fzxand post it here as pre-formatted </> text.

Seeing your computers specifications gives us more ideas where to look for.

Last but not least, did you check with with fwupd:

Hi there,
I ran journalctl -k |grep taint and it prints nothing
I also checked fwupd with fwupdmgr get-updates, it prints:

Devices with no available firmware updates: 
 • HGST HTS721010A9E630
 • MZVLW128HEGR-000H1
 • System Firmware
Devices with the latest available firmware version:
 • UEFI dbx
No updates available

For inxi -Fzx, here is the output:

System:
  Kernel: 6.0.8-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-24.fc37 Desktop: GNOME v: 43.1 Distro: Fedora release 37 (Thirty
    Seven)
Machine:
  Type: Laptop System: HP product: HP Pavilion Power Laptop 15-cb0xx
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 836B v: 46.24 serial: <superuser required> UEFI: Insyde
    v: F.41 date: 12/01/2020
Battery:
  ID-1: BAT0 charge: 69.0 Wh (97.2%) condition: 71.0/71.0 Wh (100.0%)
    volts: 16.5 min: 15.4 model: HP Primary status: discharging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185 charge: 50%
    (should be ignored) status: N/A
CPU:
  Info: quad core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
    arch: Kaby Lake rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 2133 high: 2280 min/max: 800/3800 cores: 1: 2120
    2: 2110 3: 2105 4: 2108 5: 2117 6: 2119 7: 2107 8: 2280 bogomips: 44798
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-9.5 bus-ID: 00:02.0
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard
    driver: nvidia v: 520.56.06 arch: Pascal bus-ID: 01:00.0
  Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-4:3
  Display: wayland server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa dri: iris gpu: i915
    resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.2.3
    direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound API: ALSA v: k6.0.8-300.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 05:00.0
  IF: eno1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:4
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 1.06 TiB used: 83.2 GiB (7.7%)
  ID-1: /dev/mmcblk0 vendor: SanDisk model: SD32G size: 29.72 GiB
  ID-2: /dev/nvme0n1 vendor: Samsung model: MZVLW128HEGR-000H1
    size: 119.24 GiB temp: 35.9 C
  ID-3: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB
Partition:
  ID-1: / size: 915.01 GiB used: 74.07 GiB (8.1%) fs: btrfs dev: /dev/sda4
  ID-2: /boot size: 973.4 MiB used: 277.3 MiB (28.5%) fs: ext4
    dev: /dev/sda3
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 915.01 GiB used: 74.07 GiB (8.1%) fs: btrfs
    dev: /dev/sda4
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 60.0 C pch: 56.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 684 Uptime: 16h 18m Memory: 15.39 GiB used: 6.98 GiB (45.4%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: 58
  note: see --rpm Shell: Bash v: 5.2.2 inxi: 3.3.22

Hope it helps