How to run application on Wayland?

app warns but running ok:


Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

so i tried this:


export QT_QPA_PLATFORM=wayland

now app warns and dont run, with this message:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: xcb.

Aborted (core dumped)

i found this info but could not find any solution to this…

https://fedoraproject.org/wiki/Changes/Qt_Wayland_By_Default_On_Gnome

1 Like

What application, and is this regular or flatpak?

Thanks

bitcoin-core manually installed on /usr/local/bin

Some additional info about building with wayland support here

2 Likes

Yeah, I think QT is still not so Wayland friendly. It may be okay with xwayland, but it definitely likes X better.

@charnik Please do the following, If you want to remove the variable from the exported list as well as remove its assigned value, use the unset option:

unset QT_QPA_PLATFORM

and try again to run the application in console to check the logs:

flatpak run org.bitcoincore.bitcoin-qt

Regards.,