How to run lutris with Vulkan

Hello i still search for a solution to install Vulkan on Fedora

I have a Nvidia GTX 960 and the support gave my following command to install Vulkan on Fedora:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Is there an other way how can i install Vulkan instead?

This command you used was enough to install the rpmfusion repository on Fedora, this is just one step of the process on running Vulkan games on Nvidia in a Fedora installation.

Now I’m going to give you the command to install the Nvidia driver, but be careful, if you are on GNOME (Fedora Workstation), is desirable to go on the login manager and to click on the gear symbol to select a session of GNOME with Xorg before using the following commands:

sudo dnf install xorg-x11-drv-nvidia akmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support
sudo dnf update -y

I also recommend you install Steam, it’s a great gaming platform, and it will probably get some nice packages as dependencies for you, so go to a terminal, and type:

$ sudo dnf install Steam

Type your password on the terminal and Steam is all set.

After that, probably you already have Vulkan set with your Nvidia driver. But if you want to be sure you can run the following command:

$ sudo dnf info vulkan-loader

The vulkan-loader packages in 32 and 64 bits must be listed as installed.

Of course, for your purposes, i also recommend you to install Lutris:

$ sudo dnf install lutris

And Wine, for proper Lutris functioning:

$ sudo dnf install wine

Ps: if you have some doubts with the GNOME with Xorg process, point me out, and i will upload some pictures showing you the process.

Thank you for your fast answer

lutris said that vulkan dependencies are not listed for 32 bit
which comm and should i use?

i am sry i forgot to restart the system -.-

Hmm, i was in a distribution once that said the same, but in fact i had those installed!

But you could try:

sudo dnf install vulkan-loader.i686

You could also try to just run the game and check with other people with similar hardware to yours if they have a similar performance.

You could also say the specific game you are trying to run, would be a good information.

You can also use Discord or Lutris forum to ask Lutris team direct questions. Could be useful for example to ask about this “32-bit warnings” we are talking about… it could be just a bug. Here are some useful links:

I’m a little bit confused with that declaration. :d

really it´s recommend to restart the system

i execute
sudo dnf install vulkan-loader.i686

then it´s displayed that all packages were installed.

after the restart i could run Vulkan applications

Oh, ok. I understand now.