How to set GDM display resolution/scaling/multi-monitor setup to same as Gnome desktop?

Although in Gnome desktop I have set UHD resolution, GDM always switches to FHD - which results is visible switching and blurry display of the login screen, it’s really annoying

Another point is, even when I choose to use to use single external screen, GDM always shows an extended display on both and when my laptop lid is closed I can only login “blind” because it’s on the wrong screen.

Gnome Login Menu On Wrong Screen - #2 by vgaetera

Thank you @vgaetera - however, I would like not to switch back to Xorg for GDM or do other config files hacks. I would expect that GMD (or any other GUI logon screen) should be configured via Gnome settings the usual way like I can configure the regular desktop.

At least I seem not to be the only one having these issues.

This is currently the only way to configure display settings for GDM.
And the method should work for Wayland.

All right, at first I did not entirely understand where in my file system “~gdm” is (apparently its pointing to ‘/var/lib/gdm’), but those three lines worked perfectly when executed in bash:

sudo cp -f ~/.config/monitors.xml ~gdm/.config/monitors.xml
sudo chown $(id -u gdm):$(id -g gdm) ~gdm/.config/monitors.xml
sudo restorecon ~gdm/.config/monitors.xml

Thanks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.