How to setup font of Terminal?

The space between characters is so big.


Does this matter ?

2 Likes

Install the fonts:

sudo dnf install adobe-source-code-pro-fonts

And change the font for monospace text.

4 Likes
[fedora002@localhost ~]$ su
Password: 
[root@localhost fedora002]# sudo dnf install adobe-source-code-pro-fonts
Last metadata expiration check: 0:41:26 ago on Fri 27 Nov 2020 01:12:22 PM +07.
Package adobe-source-code-pro-fonts-2.030.1.050-9.fc33.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost fedora002]#
gsettings set org.gnome.desktop.interface \
    monospace-font-name "Source Code Pro 10"

Or reset to defaults:

gsettings reset org.gnome.desktop.interface monospace-font-name
2 Likes

Ohoh!


Looks great.
Thank you so much for your support.

3 Likes

Note: terminals use “monospaced fonts”. There are many of these in the repos, so you can choose whichever you want to use and set it using tweak-tool (which is a gui for a subset of all gsettings). So, the issue here wasn’t the specific font, it was that you weren’t using a monospaced font for monospaced text (as your image of the tweak tool shows).

For example, I use the Anka-Coder condensed fonts:

Here are some more great options:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.