How to turn off display after delay?

The display on my laptop is not turning off after any delay, and I cannot find any corresponding power saving setting.

Settings -> Power has a Blank Screen option, but nothing about turning off the monitor.

I’m on Fedora 32, Gnome, and X11. This post mentions a similar issue for Wayland with no solution: Monitor does not turn off after idle on gnome wayland

In MATE, there is a Power Management option to “Put display to sleep when inactive for X minutes.”

What is the Gnome way to enable this typical power saving behavior?

The screen does not turn off, it goes into power saving mode so that it can be woken up by activity such as a mouse movement or key press. If it is turned off, it cannot be woken up. This is on both, my laptop, and my workstation which uses an external monitor.

Are you looking to suspend your laptop after a period of inactivity perhaps?

Ok, then we can call it power saving mode in which at least the backlight turns off. How to verify if it is going into power saving mode?

Typically there are three progressions: dimming the screen, “screensaver” or screen blanking where the screen turns black but the display and backlight are still on, and finally turning off the backlight and/or putting the display into sleep mode. It should wake up with any keyboard or mouse input.

The last one is not happening on my current laptop with Fedora and I see no corresponding options in Gnome Settings. My previous laptop running Ubuntu had the expected behavior.

As mentioned, MATE has an explicit option for power saving/sleep mode for the display but I see nothing similar in Gnome.

No, I’m not talking about suspending the laptop… just the display. :smiley:

Can you create a new user and see if it works there to begin with? It seems to work on both my systems so we need to ascertain if it’s a bug or some configuration in your current user.

My screens do go into power save mode immediately on locking. I don’t think there’s the intermediate “black but display and backlight are still on” phase at all. This is what I can see in the documentation. Some docs here to look at related to power:

https://help.gnome.org/users/gnome-help/stable/power.html.en#saving

Thanks, I just figured out that Synergy is blocking the power savings.

Logging into my user, or a new user, gets the screen to turn off (power saving) when the screen is locked.

If Synergy is started, the screen goes black but does not turn off (backlight still on). If Synergy is quit, the behavior remains. Restoring power saving requires logging out and in again.

That’s annoying, since I often use Synergy.

1 Like

Ah, I’m not sure if that’s a feature of Synergy or a bug. Best to check their bugtracker and perhaps report it if it isn’t known.

It must be a bug. There are several similar issues on github.

1 Like