How to update virtualbox on fedora 35 on external hard drive?

How can I update Virtual Box safely without losing my VMs when I’m using Fedora 35 on an external hard drive?

Also, Can I upgrade to fedora 36 for my situation?

Any update here ?

1 Like

I would guess that a lot more info is needed.

Is the entire system, including the VM images, contained on the same drive as the OS?

What are you using for VirtualBox? Was it installed from oracle or from the rpmfusion repo? If from the rpmfusion repo then a system upgrade to 36 should just work. If from oracle then you probably will have to manually update once the OS has been upgraded.

When I have tested VB I found that it by default created the VM images under my home directory so upgrades should not affect the actual images, merely the VB app itself.

As long as you can confirm that the VM images are not within the partition used for / and as long as this is an upgrade and not a new install there should be no unexpected issues. A new install seems to force a reformat of / but not of /home. An upgrade is just that, without anything other than upgrading the OS and apps.

2 Likes

I have installed fedora 35 on external Hard drive HDD.

Then I have I installed virtual box according this guide https://computingforgeeks.com/how-to-install-virtualbox-on-fedora-linux/
My issues :

I can’t upgrade to fedora 36 .

And
I need to know how to update virtual-box without losing my vm and data on it

Please explain this. What is preventing you doing the upgrade?

An upgrade will not normally wipe out VB, although it will necessitate that the kernel module be rebuilt for the new fedora kernel before you can restart the VMs.

If you installed VB from rpmfusion instead of oracle even that would be done for you automatically.

1 Like

I am trying to upgrade using DNF System Upgrade
https://docs.fedoraproject.org/en-US/quick-docs/dnf-system-upgrade/

After I had failed to upgrade using the first here method (my crashed many times)
https://docs.fedoraproject.org/en-US/quick-docs/upgrading/

the outputs:

[fe@fedora ~]$ sudo dnf system-upgrade download --releasever=36
[sudo] password for fe:
Before you continue ensure that your system is fully upgraded by running “dnf --refresh upgrade”. Do you want to continue [y/N]: y
Fedora 36 - x86_64 23 kB/s | 21 kB 00:00
Fedora 36 openh264 (From Cisco) - x86_64 1.9 kB/s | 989 B 00:00
Fedora Modular 36 - x86_64 30 kB/s | 20 kB 00:00
Fedora 36 - x86_64 - Updates 28 kB/s | 18 kB 00:00
Fedora Modular 36 - x86_64 - Updates 26 kB/s | 19 kB 00:00
ProtonVPN Fedora Beta repository 41 B/s | 659 B 00:15
Fedora - - VirtualBox 520 B/s | 181 B 00:00
no group ‘arm-tools’ from environment ‘workstation-product-environment’
No match for group package “qgnomeplatform”
No match for group package “reiserfs-utils”
No match for group package “authselect-compat”
No match for group package “xorg-x11-drv-armsoc”
No match for group package “culmus-shofar-fonts”
No match for group package “drehatlas-warender-bibliothek-fonts”
No match for group package “google-noto-sans-tibetan-fonts”
No match for group package “tlomt-junction-fonts”
No match for group package “google-noto-sans-syriac-estrangela-fonts”
No match for group package “google-noto-sans-syriac-eastern-fonts”
No match for group package “google-noto-sans-syriac-western-fonts”
No match for group package “drehatlas-xaporho-fonts”
No match for group package “kanjistrokeorders-fonts”
No match for group package “vollkorn-fonts”
No match for group package “khmer-os-fasthad-fonts”
No match for group package “bcm283x-firmware”
No match for group package “polarsys-b612-sans-fonts”
No match for group package “yanone-tagesschrift-fonts”
No match for group package “ubuntu-title-fonts”
No match for group package “cvsgraph”
Error:
Problem: problem with installed package VirtualBox-6.1-6.1.38_153438_fedora33-1.x86_64

  • package VirtualBox-6.1-6.1.38_153438_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.20_143896_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.22_144080_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.24_145767_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.26_145957_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.28_147628_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.30_148432_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.32_149290_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.34_150636_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.34_150636_fedora33-2.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.36_152435_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • libvpx-1.10.0-2.fc35.x86_64 does not belong to a distupgrade repository
    (try to add ‘–skip-broken’ to skip uninstallable packages)
    [fe@fedora ~]$~

That is telling you that VirtualBox installed from oracle is not part of the fedora ecosystem and cannot be upgraded.
Following all the suggestions you should

  1. sudo dnf upgrade --refresh
    If there are any errors there fix them before moving on. With VB installed as you have, you may need to use the options --best --skip-broken and maybe even --allowerasing to have that complete properly. I see references to at least 10 different versions of VB for fedora 33 there. The file libvpx.so.6 does not show anywhere within fedora or rpmfusion repos, though libvpx.so.7 shows as provided by libvpx-1.11.0-1.fc36.x86_64. The fact that file has been superseded seems the cause of your error.

  2. sudo dnf system-upgrade download --releasever 36 --skip-broken (as that message told you) to try and download everything without forcing you to uninstall VB

  3. Once the download is completed the remainder of the upgrade should work properly.

Just so you know.
Those messages are about errors with VB version 6.1.36 and the version from rpmfusion today is 6.1.38. Installing with dnf from a fedora compatible repo avoids errors of the type you are seeing.

# dnf list VirtualBox
Last metadata expiration check: 3:17:10 ago on Fri 30 Sep 2022 06:49:39 PM CDT.
Available Packages
VirtualBox.x86_64                                   6.1.38-1.fc36                                   rpmfusion-free-updates
1 Like

sudo dnf system-upgrade download --releasever 36 --skip-broken
I have tried this command and still has the same issue.
[fe@fedora ~]$ sudo dnf system-upgrade download --releasever 36 --skip-broken
Before you continue ensure that your system is fully upgraded by running “dnf --refresh upgrade”. Do you want to continue [y/N]: y
Fedora 36 - x86_64 24 kB/s | 20 kB 00:00
Fedora 36 openh264 (From Cisco) - x86_64 1.3 kB/s | 989 B 00:00
Fedora Modular 36 - x86_64 31 kB/s | 19 kB 00:00
Fedora 36 - x86_64 - Updates 15 kB/s | 14 kB 00:00
Fedora Modular 36 - x86_64 - Updates 22 kB/s | 18 kB 00:00
ProtonVPN Fedora Beta repository 21 B/s | 659 B 00:31
Fedora - - VirtualBox 255 B/s | 181 B 00:00
no group ‘arm-tools’ from environment ‘workstation-product-environment’
No match for group package “authselect-compat”
No match for group package “xorg-x11-drv-armsoc”
No match for group package “qgnomeplatform”
No match for group package “reiserfs-utils”
No match for group package “polarsys-b612-sans-fonts”
No match for group package “google-noto-sans-tibetan-fonts”
No match for group package “drehatlas-warender-bibliothek-fonts”
No match for group package “ubuntu-title-fonts”
No match for group package “culmus-shofar-fonts”
No match for group package “tlomt-junction-fonts”
No match for group package “vollkorn-fonts”
No match for group package “kanjistrokeorders-fonts”
No match for group package “google-noto-sans-syriac-estrangela-fonts”
No match for group package “drehatlas-xaporho-fonts”
No match for group package “bcm283x-firmware”
No match for group package “google-noto-sans-syriac-western-fonts”
No match for group package “yanone-tagesschrift-fonts”
No match for group package “cvsgraph”
No match for group package “google-noto-sans-syriac-eastern-fonts”
No match for group package “khmer-os-fasthad-fonts”
Error:
Problem: problem with installed package VirtualBox-6.1-6.1.38_153438_fedora33-1.x86_64

  • package VirtualBox-6.1-6.1.38_153438_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.20_143896_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.22_144080_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.24_145767_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.26_145957_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.28_147628_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.30_148432_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.32_149290_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.34_150636_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.34_150636_fedora33-2.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • package VirtualBox-6.1-6.1.36_152435_fedora33-1.x86_64 requires libvpx.so.6()(64bit), but none of the providers can be installed
  • libvpx-1.10.0-2.fc35.x86_64 does not belong to a distupgrade repository

Any official guide to install virtual-box from repo ?

  1. Stop all VMs
  2. Uninstall the VirtualBox you already have. (It should leave the configured VMs as they are)
  3. Install VB from the rpmfusion repo sudo dnf install VirtualBox
    Wait at least 5 minutes for the required VB kernel module to be built.
  4. reboot
  5. Start VirtualBox and import the VMs
    I have not done this myself so ‘not tested’ by me.
  6. test the VMs will start and run properly
  7. stop the VMs
  8. perform the system upgrade

You should be good to go.

Another alternative is to go native.
Install QEMU and libvirt then launch the VMM and import the VB vms into the VMM manager system. I believe that VMs can be imported from VB into a libvirt system or vice versa. This could be tested with a copy of one of your VM storage files before removing VB from your system.

Thanks, the system upgraded successfully .

For installing VirtualBox

outputs:

[fe@fedora ~]$ sudo dnf install VirtualBox
Last metadata expiration check: 0:05:59 ago on Sat 01 Oct 2022 04:10:07 PM EDT.
No match for argument: VirtualBox
Error: Unable to find a match: VirtualBox
[fe@fedora ~]$

OOPS.
that should have been all lowercase. I fixed it in the post above.

[fe@fedora ~]$ sudo dnf install virtualbox
Last metadata expiration check: 0:21:56 ago on Sat 01 Oct 2022 04:10:07 PM EDT.
No match for argument: virtualbox
Error: Unable to find a match: virtualbox

These are the packages from rpmfusion. Do you have the rpmfusion-free & rpmfusion-free-updates repos enabled? dnf repolist will tell you.

# dnf list virtualbox* --releasever=35
Available Packages
VirtualBox.x86_64                                                               6.1.38-1.fc35                                                rpmfusion-free-updates
VirtualBox-devel.x86_64                                                         6.1.38-1.fc35                                                rpmfusion-free-updates
VirtualBox-kmodsrc.noarch                                                       6.1.38-1.fc35                                                rpmfusion-free-updates
VirtualBox-server.x86_64                                                        6.1.38-1.fc35                                                rpmfusion-free-updates
VirtualBox-webservice.x86_64                                                    6.1.38-1.fc35                                                rpmfusion-free-updates
virtualbox-guest-additions.x86_64                                               6.1.38-1.fc35                                                updates               

I am running F36 not 35. I was uncertain if it was available for F35 so checked and found the above. It is clearly available from that repo. VirtualBox is available in several packages from rpmfusion and virtualbox-guest-additions is available from fedora.

I don’t know about virtualbox in rpmfusion but if you have the correct virtualbox repo enabled the command to install is dnf install VirtualBox-6.1