[Howto] Google chrome screen share problem (black screen) on fedora workstation 34

After installing Fedora Workstation 34, directly I’m using it for virtual meetings in google chrome. I have problems screen share, then only a blank screen here.
But, in firefox is no problem. Just enabled permission to share the screen in the fedora setting pop up.
So, here I share the solutions to solved the problem:

  1. Edit the GDM Configuration
    $ sudo vi /etc/gdm/custom.conf

  2. Edit or add this configuration be like this
    WaylandEnable=false
    DefaultSession=gnome-xorg.desktop

  3. Reboot the system and your problem is solved.

Thanks me later :slight_smile:

2 Likes

Yes, Wayland still has some quirks. It doesn’t work on my machines likewise.

Happy welcome @andrimuhyidin

This is sort of a big decision.
So basically, if I need to share screen, I need to disable Wayland.
If I need the three finger gesture and the actual blue color in browsers, FYI solved it by disabling Hardware acceleration in the browser(Brave), I need Wayland?

Wayland has a lot to improve. I would love to switch back, Wayland is a big improvement, but it has flaws like this.

Thank you