HP EliteBook 8440p - No sound through speakers

Hello, first of all I would like to clarify that I am new to Linux and new to this forum so please do let me know if I am breaking any rules and I will make any necessary corrections :slight_smile:

I just installed Fedora 34 on my HP EliteBook 8440p notebook (no dualboot) and everything seems to be working fine except the sound out of the laptop’s speakers. I have read several forums and have come to the conclusion that the problem is that AlsaMixer has PipeWire selected as the default sound card vs HDA Intel but I have no clue how to set this up in Fedora. Below are a number of steps I followed:

  1. In the Settings/Sound panel, only “Headphones - Built In Audio” is listed, so I can’t select the external speakers.

  2. I launched AlsaMixer throught the terminal, PipeWire is being used as the default sound card.

  3. I pressed F6 to select the correct sound card, selected HDA Intel MID. After selecting HDA Intel MID I can successfully see all Input/Output devices available but external speakers are muted by default.

  4. I manually un-muted external speakers and turned the volume up and this works perfect…external speakers work fine:

However once I exit AlsaMixer and exit the terminal, it all goes back to PipeWire and loose sound through external speakers.

Any ideas how to set HDA Intel MID as the default sound card?

Thanks in advance to all the community!

UDATE 1:
I was able to find the process to unsintall PipeWire in the follwing URL:
Changes/DefaultPipeWire

I have opened up AlsaMixer through the terminal and PipeWire is gone, but no sound card is selected as default (see image below), I still have to press F6 to select HDA Intel MID sound card, unmute the main speakers (steps 3 & 4 from my initial post) and will still go back to the default sound card once I exit AlsaMixer and Terminal.
image

So I still need help with setting up HDI Intel MD as the default sound card in AlsaMixer.

Any Ideas?

UPDATE 2 & SOLVED: I installed PuseAudio Control with the following command:

$ sudo dnf install pavucontrol

Once installed, I launched pavucontrol (PulseAudio Control) and manually selected the defult output…I finally have audio through the external speakers and full controll over all input/output ports of my computer. I am forced to use PulseAudio Control app vs Settings/Sound but this doesn’t bother me one bit.

I hope other people find this helpful, throughout what I was able to research, I see a lot of Linux users go through this same issue but this seems to be the easiest process to fix the problem…three easy steps:

  1. Launch AlsaMixer via the Termial to verify PipeWire is seleted as the default sound card:

$ alsamixer

  1. Uninstall PipeWire via Terminal:

$ sudo dnf swap --allowerasing pipewire-pulseaudio pulseaudio

  1. Install PulseAudio Control via Termial:

$ sudo dnf install pavucontrol

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.