نصب پرینتر HP LaserJet Professional P 1102w

driver
#1

وقت بخیر
پرینتر و با کمک cups نصب میکنم اما متاسفانه بعد از این که اقدام به پرینت گرفتن میکنم با ارور مواجه میشم
و در اعلانات این ارور و نمایش میدهد

hp:/usb/HP_LaserJet_Professional_P_1102w?serial=000000000W46A6Y5PR1a
Print job failed - required plug-in not found: Plugin missing
(root/15)

و در خود cups که در مرورگر باز کرده ام در قسمت state

stopped
“Filter failed”

( مشخصات: فدورا 30 - پرینتر HP LaserJet Professional p 1102w و cups مورد استفاده: cups-1:2.2.11-2 و
قابل ذکر که بسته hplip و هم نصب کردم)

1 Like
#2

بعد از تلاش های متعدد روش قدیمی رو پیشرفتم به این صورت که با با کمک بسته hp-setup اقدام به نصب کردم به صورت زیر

hp-setup -i

لازم به ذکر که از اونجای که hp ایران و فیلتر کرده نیاز به یک فیلتر شکن است

پس من از بسته proxychains کمک گرفتم به این صورت که بعد از نصب بسته

dnf install proxychains

اقدام کردم و بعد اقدام به تغییر کانفیگ بسته proxychains کردم به صورت زیر
به ادرس زیر مراجعه کردم و اقدام به باز کردن فایل کانفیگ کردم

/etc/proxychains.conf

و بعد در خط آخر فایل اسم socks4 رو به socks5 تغییر دادم و خارج شدم
و بعد به این صورت اقدام به نصب پلاگین کردم

proxychains hp-setup -i

و در هر مرحله تنها نیاز که Enter را بزنیم بر روی کیبورد بزنیم

2 Likes
#3

تنها سوالی که برام میمونه اینه که آیا hp-setup پلاگین های که دانلود میکنه آیا اوپن سورس است یا که خیر ؟

#4

درود
تا جایی که خبر دارم همشون اوپن سورس نبودن

1 Like
#5

پس با این اوصاف بنظر شما چه کاری بهتره که انجام بدم برای این که نیازمندی شو برطرف کنم؟
متاسفانه در توزیع آرچ نیازی به نصب پلاگین نبود و با cups انتخاب درایور میکردم و نصب میشد و تست هم میکردم درست بود اما متاسفانه اینجا این مشکل وجود داره و نیاز مند پلاگین ( یا نمیدونم شاید من دارم اشتباه میکنم و اونجا نصب میکرده پلاگین و )

#6

والا مطمئن نیستم ۱۰۰درصد ولی اگه اشتباه نکنم وقتی تو فدورا مجبور میشید با ابزار hp پلاگین نصب کنید… اون پلاگین آزاد نیست. آرچ نمیدونم چی کار کرده ولی احتمال زیاد براتون پلاگین غیرآزاد هم نصب میکنه.

البته اگه قبل از نصب پلاگین همون موقع که دارید پرینتر رو به سیستم وصل میکنید که برای بار اول شناسایی میکنه و خودش نصبش میکنه لاگ‌های سیستم رو ببینین معمولا میگه که من یه پلاگین غیرآزاد نیاز دارم که با فلان نصب میشه. حداقل من که هر وقت به این مورد خوردم پلاگین غیرآزاد لازم بوده. راه حل دیگه‌ای هم سراغ ندارم! پرینتر رو عوض کنید :smiley:

1 Like
#7

با این اوصاف آیا راه دیگه ای هست که پلاگین نصب نکنیم و بتونم از پرینتر استفاده کنم ؟
چون که با cups هم که نصب میکردم ارور پلاگین میداد و احتیاج داشت

#8

ا! همین الان جواب بالا رو ویرایش کردم. باز میتونید لاگ سیستم رو چک کنید مطمئن شید ولی راه دیگه‌ای من سراغ ندارم!

1 Like
#9

دست تون درد نکنه پس فکر کنم همون گزینه عوض کردن پرینتر و باید در نظر بگیرم برای آینده:blush:

1 Like
#10

یک مسئله دیگه میمونه اونم این که چطوری میتونم متوجه بشم چه پرینتری کاملا اوپن سورس همه چیش و راحت نصب میشه با cups و نیازی به درایور یا … غیر آزاد نداره

#11

همممم راستش تا حالا این شکلی بهش نگاه نکردم :smiley:
به نظرم وقتی یه مدل انتخاب کردید یه جستجو بکنید در موردش حتما پیدا میکنید.
البته از cups میشه یه لیست از پرینتر پشتیبانی شده دراورد (دقیق یادم نیست کجا ولی یه لیست داشت) ولی نمیدونم این پرینترهای hp که پلاگین غیرآزاد لازم دارند هم تو لیستش میاد یا نه! البته میتونی چک کنی ببینی همین پرینتر توش هست یا نه. ولی الان یادم نیست لیستش کجا بود P: بگردی باید پیداش کنی.

1 Like
#12

راستش توی لیستش هست اتفاقا پرینتر خودم و این که اتفاقا درایورش هم هست اما مسئله ای که هست همون ارور پلاگین میده که نیازش داره

#13

اهان پس در مورد hpها باید یه جایی پیدا کنی که بگه پلاگین میخوان یا نه که متاسفانه من بلد نیستم جاش رو. ولی بقیه پرینترها معمولا کلا درایور غیرآزاد میخوان و با cups پشتیبانی نمیشند. این سیستم پلاگین رو من فقط برا hp دیدم. البته خیلی از پرینترهای hp پلاگین هم نمیخوان.

1 Like
#14

من خودم HP ندارم، EPSON دارم. اما در مورد نصب پرینتر و اسکنر‌های کنون به این نتیجه رسیدم:
توی بخش پشتیبانی هر ۲ سایت کنون و اپسون، لینک درایور های مخصوص لینوکس هم هست.
این درایور‌ها رو معمولا خود کموانی‌ها نمی‌نویسن و فقط تست می‌کنن و اگر اوپن سورس بود روی سایتشون قرار میدن.
اگر از همون دراور‌هایی که روی سایت هست استفاده کنید فکر نمی‌کنم مشکلی پیش‌بیاد! همیشه من بعد از نصب درایور‌ها از سایت اپسن و کنون مشکلم بر طرف شده.
در مورد فیلتر: برای دانلود از سایت اوسن همین مشکل رو داشتم اما برای Update کردن درایور، چون پروژه‌های اوپن سورس هستند و اون محل اصلی فیلتر نیست مشکلی پیش نمیاد.

1 Like
#15

هممم همه پرینترهای کنون رو نمیدونم ولی حداقل یه مدلش رو ما قبلا یه جا داشتیم درایور باینری بود توی سایت کنون و آزاد نبود. و البته بدقلق هم بود.

2 Likes