Huawei matebook 14 (2020) amd Ryzen 7 No Sound on Fedora 35

I am not familiar with the “regular firmware” could you please fill me in with details on how to try that?

install the alsa-firmware package.

1 Like

Watch deepin is not a issue this is totally open source as far as i know. But i was saying to try it once as most of the destros have issues so maybe be deepin will also have that issue but can’t know without a try.

Yes put your bug report as that bug report is for 5.16.X prerelease you are not in that you are in released v of kernel so this report will be for your version of kernel like 5.14 or 5.15.

Deepin is a Linux distribution based on Debian’s stable branch.

It means it is always behind Fedora-Linux especially if you use Fedora Stable.

I totally agree i know that deepin is actually far behind thn fedora or arch based rolling distros but as he have tried with everything nothing worked that is why i suggest to use deepin and huawei actually sells linux laptops with deepin so maybe they have made to work with here devices. May be i am wrong but this is only hope.