I cannot access wpa_cli in terminal

I just converted an old macbook to fedora. I’m trying to set up wifi access, but when I enter wpa_cli in terminal, I get an error.

How do I procede?

Hi @dgpdx , welcome to the community!

Please take a look at the introductory posts in the #start-here category if you’ve not had the chance to do so yet.


Can you tell us what the error is please? We can’t really help unless we have specifics of what is happening.

Also—is there a reason you’re using wpa_cli instead of the standard NetworkManager tools? Either the GUI or nmcli etc.?

When I enter wpa_cli, I get this:
Interactive mode
Could not connect to wpa_supplicant: (nil) - retrying

The reason I’m using wpa_cli is that I’m following directions on how to connect to wifi that I found online. How do I use the GUI you mentioned?

Thank you for the response!

1 Like

What version of Fedora are you running with what desktop environment etc please? Could you please paste the output of fpaste --sysinfo --printonly, since that should include all of this information?

NetworkManager is the standard network management stack on Linux:

Most desktop environments have a GUI for network configuration, so that’ll be the first thing to look for. There’s a lot of information on the Arch wiki about this, for example:

https://wiki.archlinux.org/title/NetworkManager

I’m running fedora from a usb drive that was created by Fedora Media Writer.

I cannot possibly copy all the data from fpaste --sysinfo by hand and paste it here, sorry.

There is no Network Manager listed among the applications on my fedora system.
How do I add Network Manager?

Sure, but what “flavour” of Fedora is this? Workstation perhaps?

You can just run fpaste --sysinfo, and that’ll paste it to the Fedora pastebin for us.

This depends on what Fedora flavour you are using. The standard ones: workstation/KDE/spins should usually have some interface for Network Manager included in them.

(1) Yes, Workstation flavor.

(2) I’m running Fedora on a different machine from this one. How will running fpaste on that machine put the info into this forum?

(3) I don’t see Network Manager anywhere on my distribution. How can I add it?

Ah, yeh, it’ll need some manual work to fetch the info to this machine. Nevermind, this is the important bit:

If you type “network” into the search box in the activities view, you should see the network configuration shortcut in the results. That’s the network manager UI for Gnome/Workstation:

(Note that I’m on Fedora 36, so your results will probably look a little different on Fedora 35).

You should’ve also been able to go to the right hand top corner of your screen to access network settings there.

When I type “network” into the search box, I get a list of processes, none of which is wifi.

When I go into settings, I get a list of settings, again none says wifi or network.

1 Like

Can you tell us more about the MacBook you are using? Can you provide Name/Model Identifier/Part Number/Year?

1 Like

That suggests your wifi hardware may not be detected, so we’ll need some information about the hardware configuration of the machine. (I think Macs usually use Broadcomm wireless hardware, and one must install kernel drivers for those to get them to work, but we can confirm once we know what model the machine is)

It’s a 2013 MacBook Pro with Intel chip.

1 Like

Looks like this post will probably be relevant:

1 Like

Thanks for the tip.

I’m running Fedora from the usb drive. I won’t commit it to the hard drive until I know it works.

I think what I need to do is get a usb drive with Fedora 36.

Version 35 is useless to me and Fedora Media Writer won’t let me use version 36.
I will try later to get version 36.

Thank you all for the assistance!

If your hardware requires the proprietary Broadcom drivers, you will also need to install them on F36 from RPM Fusion yourself—this has not changed recently from what I know.

F36 is not yet available on Fedora media writer because it has not yet been released. It is expected to release on the 10th:

https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

So what you need to check is what wireless hardware you have, and then check to see if the kmod-wl package from RPM Fusion supports it.

Fedora does not include proprietary software because we’re a Free/Open source community/distribution, but there will be other Linux distributions that may.

1 Like

I’ll check back on the 10th. Thank you for the info.