i915: unknown parameter 'i915' ignored

Yesterday I installed Fedora 30 in my PC. All ok.
I’m configuring, installing and etc… But I have found this warning in dmesg output:

...
[    2.584463] r8169 0000:01:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    2.585299] sd 4:0:0:0: [sdc] Attached SCSI disk
[    2.597110] r8169 0000:01:00.0 enp1s0: renamed from eth0
[    2.677359] logitech-djreceiver 0003:046D:C52B.0003: hiddev96,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
[    2.728629] Setting dangerous option enable_guc - tainting kernel
[    2.728631] i915: unknown parameter 'i915' ignored
[    2.729461] checking generic (c0000000 7e9000) vs hw (c0000000 10000000)
[    2.729462] fb0: switching to inteldrmfb from EFI VGA
[    2.729501] i915 0000:00:02.0: vgaarb: deactivate vga console
[    2.730477] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    2.730477] [drm] Driver supports precise vblank timestamp query.
....

I don’t know what i915: unknown parameter 'i915' ignored means. In none of the configuration files present in /etc/modprobe.d/ are there any parameters for the i915 module.

I guess it’s in your cmdline, see:

cat /proc/cmdline

cmdline is build from /etc/default/grub (the line with GRUB_CMDLINE_LINUX) during kernel install and grub2-mkconfig .

please show us your output of the above cat command !

i915 is the driver for your intel graphic card btw.
To my GRUB_CMDLINE_LINUX I have manual added i915.enable_guc=3 which loads firmware (GuC and HuC) [1] and that taints the kernel

Parameter for i915 see

modinfo i915.

what the FW is good for see:

https://01.org/linuxgraphics/downloads/firmware

if you feedle with /etc/default/grub you afterwards need to run

sudo grub2-mkconfig …

[1]
see if FW is loaded correct

dmesg | grep drm | grep -E ‘GuC|HuC’

1 Like

That warning is with Fedora new fresh install and none parameter added to kernel cmdline or `/etc/modprobe.d/.
This is the default cmdline:

BOOT_IMAGE=(hd1,gpt2)/vmlinuz-5.2.13-200.fc30.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet 

But I have added several options:
spectre_v2=off nopti i915.modeset=1 pcie_aspm=force scsi_mod.use_blk_mq=1

and I have added another i915 options in modprobe conf file:

$ cat /etc/modprobe.d/i915.conf 
options i915 fastboot=1
options i915 enable_guc=2

The i915 options added for me work well. I had the same in Arch Linux (my previous OS).
I think that warning could be a bug but I can’t find the parameter that triggers that warning.

1 Like

confused !

you could try to boot with the parameter for i915 alone to see if that triggers you error.

another thought is:
are you sure that in your /etc/modprobe.d/i915.conf the two “options i915” are valid ?
And if so: are the line endings correct ?

you maybe try with just one line in it:

options i915 fastboot=1 enable_guc=2

see:

2 Likes

It works both ways.

Thanks for the answers but as I said the error occurs from the installation (the day before) without me having added any parameter to the module i915.
Since it’s a warning, I think it’s best not to give it more importance.