In dual boot, Windows 10 did not go to grub menu after restarting

Selecting Fedora 34 and restarting, Fedora always goes to grub menu.
But selecting Windows 10 and restarting, Windows 10 goes to black screen.
How can Windows 10 go to grub menu after restarting ?

I just finish test boot.

My BIOS machine will always show the grub menu - I have the auto hide disabled as per How to disable grub2 menu auto hide?

For me, it says like a Windows fast startup or hibernation issue. (As Windows will just restart from hibernation instead of going through the complete boot process).

I will try to disable them and test to see if it helps.

An alternative to disabling auto-hiding of the GRUB menu is to just hold down the Shift key while booting when you want the GRUB menu. (Hitting Esc or F8 at the right time should also work, but that can be harder to get right).

With fedora and dual boot with windows on mine it always shows the grub menu without needing the step of disabling the hidden grub menu. On my machine that does not dual boot I did have to disable the hidden menu.

I did find out the hard way that if the bios/UEFI is set to fast boot then the only way to get into the bios again (and the grub menu) is either through the OS (windows allows that from the OS, although grub only allows it from the boot menu) or by draining the cmos so it goes back to factory default.

I would guess from your question that you are somehow booting windows without using grub, instead of always shutting it down and doing a clean boot each time. I have read that if you hibernate or suspend windows then boot linux that it interferes with grub.

I just solved the problem of notebook#1 on this question.
After solving, restarting either Windows 10 or Fedora 34 - it went to grub menu smoothly.

But this question if for my notebook#2, both notebooks are the same brand and model. How can I compare and find the difference setup ?

I decided to reinstall Windows 10 version 21H1 directly into its specific drive as seen in Disk Management.
Now either Fedora 34 or Windows 10 Home goes to grub menu after restarting.
:grinning_face_with_smiling_eyes:

That seems to have fixed the windows boot loader.

1 Like