Incorrect display of the сyrillic name in the panel GNOME

Hello all!
Could you help me or indicate a possible way to solve the problem.
I have software, which have сyrillic name (russian). In Nautilus name displayed correctly. But when I run them, in panel GNOME name displayed incorrect.

Thanks.

Please advise, maybe I should write to the GNOME developers and specify where the text encoding for the panel is indicated?

Is this after installing it for the first time? If so, did you reboot or log out and log back in?

ersen, at first thanks for your reply

  1. This software - without installation, it is own development in IDE for specialized calculations.
  2. It does not depend on a reboot, etc., it depends on the name of the executable file.
  3. In Nautilus all ok:picture

I assume that the problem is related to the encoding that is in some GNOME configuration file, since there are no problems in Nautilus, but I am not familiar with the internal structure of GNOME settings.

This doesn’t mean you have the necessary fonts installed on your system. Its only 6 characters. Make sure you have the necessary fonts installed, log out and log back in.

Thanks for your direction!
This bug not only for 6 characters-it’s for all сyrillic letter (russian).

At first, I try change font in gnome-tweak-tools:


And nothing change.

Then I try search another information: how I understand must be yet one font - fifth, for top bar GNOME.

Could you show me where is in F31, with default setup, place with this config file? My quick search failed…

And so, topic not close yet, because not solve…
I didn’t found GNOME Shell config file for default theme and I install another theme:

.
Then I found config file for this theme: /usr/share/gnome-shell/theme/gnome-shell.css and there are Cantarell, Sans-Serif:
.
I think they support Cyrillic, or wrong?
After change theme and reboot problem stay:
In top:top ,
In bottom: button.

May be problem not on font? My be problem in some system encoding?