Input timing not supported by the monitor display

Hi There – I tried sudo startx, got the same error with the X keyboard compiler. I have the log file /var/log/Xorg.0.log but can;t seem to be able to upload it here. Is there a way I can get it to you ?

From reading it, it seems X is recognizing my mouse, keyboard, and even graphics card as keyboards …? or maybe I am misunderstnading… also, seems it is using 2048x1152 as default resolution for some reason. Also, the file shows 1920x1080 is a standard and recognized resolution by my monitor.

…goint to bed now, late here, almost 1am

No need to switch, Mate not runs wayland yet.

Windows is proprietary software as well Nvidia, do not expect same behavior on Linux as Windows.

Unless noted you should not need to be logged in as root, but rather as your regular user. The error message above indicates you may have been logged in as root and that may have prevented X from starting.

I looked at the nvidia site and the GTX460 is supported by the nvidia 470.xx drivers.

I need to ask, were the nvidia drivers installed directly from nvidia or from rpmfusion?
If they were installed from nvidia they would not have been rebuilt for use with the upgrade until you were able to do so manually.
If they were installed from rpmfusion they should have been upgraded at the same time the system was upgraded, but that also presents an issue since the latest nvidia drivers (495.44) that were released coincident with fedora 35 also dropped support for some of the older cards that were properly supported with the 470.xx drivers.

I suggest you boot to run level 3, then run sudo dnf list installed \*nvidia\* and sudo dnf repolist. Post the output of both commands here and we should be able to find a path forward from that info.

Just find a way to change the resolution (I tested with Fedora Mate 31, and btw turn out it use lightdm and not sddm).

First find your monitor name. It could be done by ls /sys/class/drm.

[testcase@fedora ~]$ ls /sys/class/drm
card0  card0-eDP-1  card0-HDMI-A-1  renderD128  version

From above example, by removing card0-*, my main monitor is eDP-1. Your monitor name could be different.

Create script sudo touch /etc/lightdm/xrandr.sh then edit it and add:

#!/bin/sh

xrandr --output eDP1 --mode 1024x768 --dpi 96

In my case, adding monitor refresh rate still make the lightdm doesn’t work. Above only change the resolution (please try with your preference) and dpi.

Make it executable sudo chmod /etc/lightdm/xrandr.sh

Open and edit sudo vim /etc/lightdm/lightdm.conf find part [Seat:*], then bellow it, find #display-setup-script=. Uncomment and change to display-setup-script=/etc/lightdm/xrandr.sh and save it.

Then sudo systemctl restart lightdm. If above success, the login screen will showup.

If it fail, and the monitor only showing blinking underscore, you could repeat again with different resolution by modifying /etc/lightdm/xrandr.sh by pressing first ctr+alt+F3 to go back to tty.

Source here and I modified some step for your tty env.

Update:

We could also find current available resolution. From above example:

cat /sys/class/drm/card0-eDP-1/modes

@oprizal
Please lets work on only one thing at a time. If too many changes are made then it can introduce more problems.

I would like to get the driver issue sorted and if that does not work then we can go further, but I suspect the driver for the nvidia card is the issue so please let the OP work on that first before digging deeper.

1 Like

@computersavvy I’m sorry. I just know that you already post before me. I didn’t realize it. I’m too focus writing the steps. My bad.

No Problem, I just would prefer to avoid confusion and work on things in an orderly manner.
You’re good.
We approach problems from a different perspective and that makes more solutions visible depending on how the issue is viewed. I tend to look at the simplest solution first.

Hi There, sneaking out of my day job to post this reply quick. I did run startx both ways, under su and sudo. You are correct the driver did no tload when under su. But did with sudo. I will rerun so I can show the errors, and also get the info you need on NVIDIA drivers. I did build F32 with the rpmfusion nividia drivers and all had been running fine until the monitor change.

the file log file /var/log/Xorg.0.log to me seems that there is realliy an issue with the xkbcomp. I have the file but not sure how to post, it is quite long, and seems I cannot attach here…? Will be back later on

You should not need anything other than your regular user to run startx.
Try it by logging in as your regular user then run startx without sudo. It should work that way.

Ah, you mentioned one thing I forgot. Changing the monitor may also require rebuilding the driver to match the hardware.
I suggest that you also, before you do the startx step, do sudo dnf reintstall akmod-nvidia so the system will rebuild that kernel module. Then reboot to see if there is a change. If that does not work then we will look at the drivers and see if that is the issue.

Hi Guys,
Thank you for your patience, have managed to take the last hours of Friday afternoon off work to get onto this.
Actual outputs below.
First, I may need to apologize, since it looks like I never did install the Nvidia drivers (though I fully meant to, since I do have the RPM-fusion reps linked) and am apparently running the nouveau drivers.
So, one first question: can I install the Nvidia drivers from the console using:
sudo dnf install akmod-nvidia ? maybe if I do this now all issues will go away ?

I also recalled from my days using Unix in the 1980’s how to capture output from commands, and how to mount my windows drive to transfer the file, so no more pictures to post.

This is the console+error output from runnning $startx (no sudo, no su)

xauth: file /home/zook/.serverauth.1246 does not exist
X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: 5.11.10-200.fc33.x86_64
Current Operating System: Linux Virago 5.11.22-100.fc32.x86_64 #1 SMP Wed May 19 18:58:25 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=(hd1,msdos1)/vmlinuz-5.11.22-100.fc32.x86_64 root=UUID=6c513fec-3dc8-46a3-aa57-5cc5f15f6cc6 ro resume=UUID=e25cfaa1-20b1-48cb-870c-289b387a1758 rd.md.uuid=3ddbfb18:dbda48b7:ffbedba5:9605e8f9 rd.md.uuid=be378bd8:feb636a7:9fbb05ea:5ac10ac3 selinux=0 3
Build Date: 14 April 2021 12:00:00AM
Build ID: xorg-x11-server 1.20.11-1.fc32
Current version of pixman: 0.40.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/home/zook/.local/share/xorg/Xorg.0.log”, Time: Fri Jan 7 15:07:54 2022
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
The XKEYBOARD keymap compiler (xkbcomp) reports:

Internal error: Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server
xinit: connection to X server lost waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

This is the console+error output from running $sudo startx

xauth: file /root/.serverauth.1254 does not exist
X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: 5.11.10-200.fc33.x86_64
Current Operating System: Linux Virago 5.11.22-100.fc32.x86_64 #1 SMP Wed May 19 18:58:25 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=(hd1,msdos1)/vmlinuz-5.11.22-100.fc32.x86_64 root=UUID=6c513fec-3dc8-46a3-aa57-5cc5f15f6cc6 ro resume=UUID=e25cfaa1-20b1-48cb-870c-289b387a1758 rd.md.uuid=3ddbfb18:dbda48b7:ffbedba5:9605e8f9 rd.md.uuid=be378bd8:feb636a7:9fbb05ea:5ac10ac3 selinux=0 3
Build Date: 14 April 2021 12:00:00AM
Build ID: xorg-x11-server 1.20.11-1.fc32
Current version of pixman: 0.40.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Fri Jan 7 12:10:09 2022
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
The XKEYBOARD keymap compiler (xkbcomp) reports:

Internal error: Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server
Failed to import environment: Process org.freedesktop.systemd1 exited with status 1
xinit: connection to X server lost waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

This is the output from running $sudo dnf list installed *nvidia*

Error: No matching Packages to list

This is the output from running $sudo dnf repolist

repo id repo name
fedora Fedora 32 - x86_64
fedora-cisco-openh264 Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 32 - x86_64
rpmfusion-free RPM Fusion for Fedora 32 - Free
rpmfusion-free-updates RPM Fusion for Fedora 32 - Free - Updates
updates Fedora 32 - x86_64 - Updates
updates-modular Fedora Modular 32 - x86_64 - Updates

I also grep’d the /var/log/Xorg.0.log file for “driver” and "keyboard"
Output from grep driver:

[ 918.979] X.Org XInput driver : 24.1
[ 919.104] (==) Matched modesetting as autoconfigured driver 0
[ 919.104] (==) Matched fbdev as autoconfigured driver 1
[ 919.104] (==) Matched vesa as autoconfigured driver 2
[ 919.104] (==) Assigned the driver to the xf86ConfigLayout
[ 919.104] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 919.105] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 919.105] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 919.105] (II) FBDEV: driver for framebuffer: fbdev
[ 919.105] (II) VESA: driver for VESA chipsets: vesa
[ 919.402] (II) modeset(0): [DRI2] DRI driver: nouveau
[ 919.402] (II) modeset(0): [DRI2] VDPAU driver: nouveau
[ 919.491] ABI class: X.Org XInput driver, version 24.1
[ 919.491] (II) Using input driver ‘libinput’ for ‘Power Button’
[ 919.497] (II) Using input driver ‘libinput’ for ‘Power Button’
[ 919.501] (II) No input driver specified, ignoring this device.
[ 919.502] (II) No input driver specified, ignoring this device.
[ 919.502] (II) No input driver specified, ignoring this device.
[ 919.502] (II) No input driver specified, ignoring this device.
[ 919.503] (II) No input driver specified, ignoring this device.
[ 919.503] (II) No input driver specified, ignoring this device.
[ 919.504] (II) No input driver specified, ignoring this device.
[ 919.504] (II) No input driver specified, ignoring this device.
[ 919.505] (II) No input driver specified, ignoring this device.
[ 919.505] (II) No input driver specified, ignoring this device.
[ 919.506] (II) No input driver specified, ignoring this device.
[ 919.506] (II) No input driver specified, ignoring this device.
[ 919.507] (II) Using input driver ‘libinput’ for ‘Logitech G9x Laser Mouse’
[ 919.566] (II) No input driver specified, ignoring this device.
[ 919.568] (II) Using input driver ‘libinput’ for ‘Logitech G9x Laser Mouse Keyboard’
[ 919.576] (II) Using input driver ‘libinput’ for ‘Logitech G9x Laser Mouse Consumer Control’
[ 919.585] (II) Using input driver ‘libinput’ for ‘Plantronics Plantronics Blackwire 5220 Series’
[ 919.595] (II) Using input driver ‘libinput’ for ‘Metadot - Das Keyboard Das Keyboard’
[ 919.605] (II) Using input driver ‘libinput’ for ‘Metadot - Das Keyboard Das Keyboard Consumer Control’
[ 919.614] (II) Using input driver ‘libinput’ for ‘Metadot - Das Keyboard Das Keyboard System Control’
[ 919.624] (II) No input driver specified, ignoring this device.
[ 919.636] (II) Using input driver ‘libinput’ for ‘Logitech G9x Laser Mouse Consumer Control’
[ 919.636] (**) Option “_source” “_driver/libinput”

Output from grep keyboard

[ 919.485] () Power Button: Applying InputClass “evdev keyboard catchall”
[ 919.485] (
) Power Button: Applying InputClass “libinput keyboard catchall”
[ 919.485] () Power Button: Applying InputClass “system-keyboard”
[ 919.494] (II) event1 - Power Button: is tagged by udev as: Keyboard
[ 919.495] (II) event1 - Power Button: device is a keyboard
[ 919.496] (II) event1 - Power Button: is tagged by udev as: Keyboard
[ 919.496] (II) event1 - Power Button: device is a keyboard
[ 919.497] (
) Power Button: Applying InputClass “evdev keyboard catchall”
[ 919.497] () Power Button: Applying InputClass “libinput keyboard catchall”
[ 919.497] (
) Power Button: Applying InputClass “system-keyboard”
[ 919.498] (II) event0 - Power Button: is tagged by udev as: Keyboard
[ 919.498] (II) event0 - Power Button: device is a keyboard
[ 919.500] (II) event0 - Power Button: is tagged by udev as: Keyboard
[ 919.500] (II) event0 - Power Button: device is a keyboard
[ 919.568] (II) config/udev: Adding input device Logitech G9x Laser Mouse Keyboard (/dev/input/event3)
[ 919.568] () Logitech G9x Laser Mouse Keyboard: Applying InputClass “evdev keyboard catchall”
[ 919.568] (
) Logitech G9x Laser Mouse Keyboard: Applying InputClass “libinput keyboard catchall”
[ 919.568] () Logitech G9x Laser Mouse Keyboard: Applying InputClass “system-keyboard”
[ 919.568] (II) Using input driver ‘libinput’ for ‘Logitech G9x Laser Mouse Keyboard’
[ 919.568] (
) Logitech G9x Laser Mouse Keyboard: always reports core events
[ 919.571] (II) event3 - Logitech G9x Laser Mouse Keyboard: is tagged by udev as: Keyboard
[ 919.571] (II) event3 - Logitech G9x Laser Mouse Keyboard: device is a keyboard
[ 919.572] (II) event3 - Logitech G9x Laser Mouse Keyboard: device removed
[ 919.572] (II) XINPUT: Adding extended input device “Logitech G9x Laser Mouse Keyboard” (type: KEYBOARD, id 9)
[ 919.574] (II) event3 - Logitech G9x Laser Mouse Keyboard: is tagged by udev as: Keyboard
[ 919.575] (II) event3 - Logitech G9x Laser Mouse Keyboard: device is a keyboard
[ 919.576] () Logitech G9x Laser Mouse Consumer Control: Applying InputClass “evdev keyboard catchall”
[ 919.576] (
) Logitech G9x Laser Mouse Consumer Control: Applying InputClass “libinput keyboard catchall”
[ 919.576] () Logitech G9x Laser Mouse Consumer Control: Applying InputClass “system-keyboard”
[ 919.580] (II) event4 - Logitech G9x Laser Mouse Consumer Control: is tagged by udev as: Keyboard
[ 919.580] (II) event4 - Logitech G9x Laser Mouse Consumer Control: device is a keyboard
[ 919.583] (II) event4 - Logitech G9x Laser Mouse Consumer Control: is tagged by udev as: Keyboard
[ 919.583] (II) event4 - Logitech G9x Laser Mouse Consumer Control: device is a keyboard
[ 919.585] (
) Plantronics Plantronics Blackwire 5220 Series: Applying InputClass “evdev keyboard catchall”
[ 919.585] () Plantronics Plantronics Blackwire 5220 Series: Applying InputClass “libinput keyboard catchall”
[ 919.585] (
) Plantronics Plantronics Blackwire 5220 Series: Applying InputClass “system-keyboard”
[ 919.589] (II) event8 - Plantronics Plantronics Blackwire 5220 Series: is tagged by udev as: Keyboard
[ 919.589] (II) event8 - Plantronics Plantronics Blackwire 5220 Series: device is a keyboard
[ 919.593] (II) event8 - Plantronics Plantronics Blackwire 5220 Series: is tagged by udev as: Keyboard
[ 919.593] (II) event8 - Plantronics Plantronics Blackwire 5220 Series: device is a keyboard
[ 919.595] (II) config/udev: Adding input device Metadot - Das Keyboard Das Keyboard (/dev/input/event5)
[ 919.595] () Metadot - Das Keyboard Das Keyboard: Applying InputClass “evdev keyboard catchall”
[ 919.595] (
) Metadot - Das Keyboard Das Keyboard: Applying InputClass “libinput keyboard catchall”
[ 919.595] () Metadot - Das Keyboard Das Keyboard: Applying InputClass “system-keyboard”
[ 919.595] (II) Using input driver ‘libinput’ for ‘Metadot - Das Keyboard Das Keyboard’
[ 919.595] (
) Metadot - Das Keyboard Das Keyboard: always reports core events
[ 919.599] (II) event5 - Metadot - Das Keyboard Das Keyboard: is tagged by udev as: Keyboard
[ 919.599] (II) event5 - Metadot - Das Keyboard Das Keyboard: device is a keyboard
[ 919.599] (II) event5 - Metadot - Das Keyboard Das Keyboard: device removed
[ 919.599] (II) XINPUT: Adding extended input device “Metadot - Das Keyboard Das Keyboard” (type: KEYBOARD, id 12)
[ 919.603] (II) event5 - Metadot - Das Keyboard Das Keyboard: is tagged by udev as: Keyboard
[ 919.603] (II) event5 - Metadot - Das Keyboard Das Keyboard: device is a keyboard
[ 919.605] (II) config/udev: Adding input device Metadot - Das Keyboard Das Keyboard Consumer Control (/dev/input/event7)
[ 919.605] () Metadot - Das Keyboard Das Keyboard Consumer Control: Applying InputClass “evdev keyboard catchall”
[ 919.605] (
) Metadot - Das Keyboard Das Keyboard Consumer Control: Applying InputClass “libinput keyboard catchall”
[ 919.605] () Metadot - Das Keyboard Das Keyboard Consumer Control: Applying InputClass “system-keyboard”
[ 919.605] (II) Using input driver ‘libinput’ for ‘Metadot - Das Keyboard Das Keyboard Consumer Control’
[ 919.605] (
) Metadot - Das Keyboard Das Keyboard Consumer Control: always reports core events
[ 919.609] (II) event7 - Metadot - Das Keyboard Das Keyboard Consumer Control: is tagged by udev as: Keyboard
[ 919.609] (II) event7 - Metadot - Das Keyboard Das Keyboard Consumer Control: device is a keyboard
[ 919.609] (II) event7 - Metadot - Das Keyboard Das Keyboard Consumer Control: device removed
[ 919.609] (II) XINPUT: Adding extended input device “Metadot - Das Keyboard Das Keyboard Consumer Control” (type: KEYBOARD, id 13)
[ 919.612] (II) event7 - Metadot - Das Keyboard Das Keyboard Consumer Control: is tagged by udev as: Keyboard
[ 919.613] (II) event7 - Metadot - Das Keyboard Das Keyboard Consumer Control: device is a keyboard
[ 919.614] (II) config/udev: Adding input device Metadot - Das Keyboard Das Keyboard System Control (/dev/input/event6)
[ 919.614] () Metadot - Das Keyboard Das Keyboard System Control: Applying InputClass “evdev keyboard catchall”
[ 919.614] (
) Metadot - Das Keyboard Das Keyboard System Control: Applying InputClass “libinput keyboard catchall”
[ 919.614] () Metadot - Das Keyboard Das Keyboard System Control: Applying InputClass “system-keyboard”
[ 919.614] (II) Using input driver ‘libinput’ for ‘Metadot - Das Keyboard Das Keyboard System Control’
[ 919.615] (
) Metadot - Das Keyboard Das Keyboard System Control: always reports core events
[ 919.618] (II) event6 - Metadot - Das Keyboard Das Keyboard System Control: is tagged by udev as: Keyboard
[ 919.618] (II) event6 - Metadot - Das Keyboard Das Keyboard System Control: device is a keyboard
[ 919.619] (II) event6 - Metadot - Das Keyboard Das Keyboard System Control: device removed
[ 919.619] (II) XINPUT: Adding extended input device “Metadot - Das Keyboard Das Keyboard System Control” (type: KEYBOARD, id 14)
[ 919.622] (II) event6 - Metadot - Das Keyboard Das Keyboard System Control: is tagged by udev as: Keyboard
[ 919.622] (II) event6 - Metadot - Das Keyboard Das Keyboard System Control: device is a keyboard
[ 919.636] () Logitech G9x Laser Mouse Consumer Control: Applying InputClass “evdev keyboard catchall”
[ 919.636] (
) Logitech G9x Laser Mouse Consumer Control: Applying InputClass “libinput keyboard catchall”
[ 919.636] (**) Logitech G9x Laser Mouse Consumer Control: Applying InputClass “system-keyboard”
[ 920.178] (II) event3 - Logitech G9x Laser Mouse Keyboard: device removed
[ 920.178] (II) event5 - Metadot - Das Keyboard Das Keyboard: device removed
[ 920.178] (II) event7 - Metadot - Das Keyboard Das Keyboard Consumer Control: device removed
[ 920.178] (II) event6 - Metadot - Das Keyboard Das Keyboard System Control: device removed

GOOD NEWS !

…went ahead and installed the RPM-nonfree repo, and the Nvidia 390xx drivers for my card…

I am able to get to the GUI now, though upon booting I get an odd screen first, and after a few seconds I get the login page. All good for now.

THANK YOU to you both !!! your gut feeling it was display driver issue was right on !

Very Best Regards !

…any way I can get a beer to you guys ? eTransfer ?

…so I suppose the overall solution was that the nouveau driver didi not like my new monitor (something to note), and I needed to install RPM-fusion Nvidia driver to make it work.

I think that the card you have was supported by the 440.xx driver in fedora 32. That is a better driver than 390 for the newer cards and if it works then the 470 driver should work as well when you actually update the system. The 470 driver is the latest for fedora 34 and you would not likely encounter problems until you update to fedora 35. There you would probably need to stay with the 470xx driver instead of the 495 driver.

Glad you got that sorted out. :+1:

Thanks again for the note JV. I woud not have fixed it withouth you guys’s help – my initial thoughts were that everything had been working fine and that it was an issue with Fedora, not my installation. So MANY thanks again for the help.

I will upgrade to 34, at least for now, as I plan to get a new machine this summer sometime.

Just in case, how do I change from teh 390xx driver to the 440 or 470xx driver ? Do I have to uninstall the 390 driver and then install the newer one after ?

Cheers!

You should be able to do sudo dnf swap akmod-nvidia-390* akmod-nvidia-440* --allowerasing to swap the driver while running fedora 32. Then when you upgrade to fedora 34 it will automatically upgrade the driver to the 470 version.

Thank you !