Installation of Fedora 30 - Black Screen

Hi to All…

I boot from a PenDrive with Fedora 30. My purpose is to update from Fedora 29 which is working well. My Laptop is an Alienware Mx11R2 with Nvidia Hybrid Graphics. The Pendrive has been used successfully in two other prior installations.

Once the Laptop boots from the PenDrive, it never gets to the installation screen where you choose to install or test Live. The installation gets stuck at a black screen where I can see and use the mouse cursor.

The Laptop does not freeze but I have no options…

Any ideas…?

This issue does not happen in Fedora 29 where installation runs smooth until the end… and updates have never created issues.

When you encounter an issue like this, press CTRL+ALT+F2 to open TTY2 and, at the prompt, change directory into /tmp:

cd /tmp

This is where Anaconda stores the logs during installation. Check the output of the X.log file to see if any problems are listed. If possible, use FPaste to paste the logs and then link them here:

fpaste /tmp/X.log
fpaste /tmp/anaconda.log

Hi:

Sorry for the delay; was out of the country.

I have done as told. There is no such X.log nor anaconda.log file. Only 7 “systemd…” and one “tracker-extract…” files in /tmp folder.

Installation is stuck at first black screen during first boot. Fedora stopped. I can see the cursor and move it. CTRL-ALT-F2 did not take me to prompt but CTRL-ALT-F3 did.

This behavior is not present is Fedora 29 as it gets smoothly to first installation screen.

I’ll appreciate all the help available.

@solrac, right after you select to boot from your pendrive, there’s a boot menu with entries like “Start Fedora Live something…” and “Test this media and start Fedora something…”.

There should also be a “Troubleshooting …” menu entry, and in a submenu something like “Start Fedora in basic graphics mode” (i’m writing this from memory).

Blackscreen can be connected with graphics driver, and boot option I mention have helped me several times in the past.

Try adding nouveau.modeset=0 to your grub line on boot. My son had the same issue on intel/nvidia hybrid graphics and needed this. If that works there are some great web pages that show hot to setup hybrid graphics online like this one https://www.internetstaff.com/fedora-28-on-dell-xps-15/

The only thing i needed to change from his site is “sudo systemctl disable nvidia-fallback” needed to be “sudo systemctl mask nvidia-fallback” disable only stop it from loading but allows other services to load if as a dependence. Masking it point it to a blank file so even if they load it, nothing happens.

Tim

Thanks…

I’ll be trying all suggestions right away…and will get back with the results.

Thank you all…

I got it to work as stated: “Try adding nouveau.modeset=0 to your grub line on boot”. This made the difference… Later on I had to deal with getting Intel Drivers working but this made the difference. The Laptop is up and running Fedora 30.

There are still issues that have to do with Hybrid Graphics but I guess that in time all will work…

I guess patience…