Installation of Fedora 36 armhfp hangs on Installation Source

I’m trying to install Fedora 36 armhfp on Qemu using anaconda in text mode and anaconda appears to hang when I select the Installation Source option. I am able to configure the installation destination correctly using anaconda option 5. Installation Destination. When I try option 3. Installation source anaconda seems to hang, even Ctrl + b 3 does not work.
Screenshot from 2022-09-06 07-17-57

Reproducing steps:

wget https://mirror.lstn.net/fedora/releases/36/Server/armhfp/iso/Fedora-Server-netinst-armhfp-36-1.5.iso
sudo mount -o ro Fedora-Server-netinst-armhfp-36-1.5.iso /mnt
cp /mnt/images/pxeboot/vmlinuz-lpae /mnt/images/pxeboot/initrd-lpae.img .
sudo umount /mnt
qemu-img create -f qcow2 fedora.qcow2 16G

sudo qemu-system-arm -M virt -kernel ./vmlinuz-lpae -initrd ./initrd-lpae.img -nographic -m 1024M -append "console=ttyAMA0" -drive file=Fedora-Server-netinst-armhfp-36-1.5.iso,id=cdrom,if=none,media=cdrom -device virtio-scsi-device -device scsi-cd,drive=cdrom -netdev tap,id=hostnet0 -device virtio-net-device,netdev=hostnet0,id=net0 -drive file=fedora.qcow2,id=hd,if=none -device virtio-blk-device,drive=hd

You will also need to install /etc/qemu-ifup You can copy it from some tar file see Network emulation — QEMU documentation or you can copy it from a Debian-based system, it’s in the qemu-system-common package. It’s documented, just run qemu-system-arm --help and part of the output will be:

qemu -netdev ... [,script=file][,downscript=dfile]
 use network scripts 'file' (default=/etc/qemu-ifup)
 to configure it and 'dfile' (default=/etc/qemu-ifdown)

I was able to install Debian in a similar way so my approach is tenable. See:

Is there a better way to get a working Fedora 36 armhfp virtual machine?

I’m curious why you don’t just use one of the pre-built images for this?

https://arm.fedoraproject.org/

Otherwise, the issue might be that you are attempting a net install, which depends on networking be up. It might be work booting an image from the link above to troubleshoot networking with qemu against the pre-built image and maybe that might give you an idea of what you might need to tweak to get the network up for the net installation method.

Too late, my VM boots up.

Very cool. Please post the solution here so the next person can benefit from what you learned.

Soon…

Here’s my documenation:

1 Like