Installing Inkscape 0.91 on Fedora 31

I want to install Inkscape 0.91 on Fedora 31, as it has native support for one of the plugins I need to use.

So far I have tried this
with dnf --showduplicates list inkscape the oldest version is 0.92.

I downloaded the rpm for 0.91 https://inkscape.org/release/inkscape-0.91/
and tried to install manually/from sources, but it leads to many dependencies which are not found or are not compatible.
Running ./config halts with these errors

configure: error: Package requirements (bdw-gc >= 7.1
cairo >= 1.10
cairomm-1.0 >= 1.9.8
glib-2.0 >= 2.28
glibmm-2.4 >= 2.28
giomm-2.4
gsl
gthread-2.0 >= 2.0
libpng >= 1.2
libxml-2.0 >= 2.6.11
libxslt >= 1.0.15
pango >= 1.24
pangoft2 >= 1.24
sigc++-2.0 >= 2.0.12
) were not met:

Package 'bdw-gc', required by 'virtual:world', not found
Package 'cairo', required by 'virtual:world', not found
Package 'cairomm-1.0', required by 'virtual:world', not found
Package 'glib-2.0', required by 'virtual:world', not found
Package 'glibmm-2.4', required by 'virtual:world', not found
Package 'giomm-2.4', required by 'virtual:world', not found
Package 'gsl', required by 'virtual:world', not found
Package 'gthread-2.0', required by 'virtual:world', not found Package ‘libxml-2.0’, required by ‘virtual:world’, not found Package ‘libxslt’, required by ‘virtual:world’, not found Package ‘pango’, required by ‘virtual:world’, not found Package ‘pangoft2’, required by ‘virtual:world’, not found Package ‘sigc+±2.0’, required by ‘virtual:world’, not found`

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables INKSCAPE_CFLAGS
and INKSCAPE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I tried installing bdw-gc but it is not found in dnf

No match for argument: bdw-gc
Error: Unable to find a match: bdw-gc

The other packages like cairo etc are installed.

How can this be resolved?

Possibly, by building it from sources.
Download tarball, tar -xf it, then read the “README”, “INSTALL”, and the such files.  Because of frequent Fedora updates, it’s looks worthy to invest the time and set up a “snap”.  Currently, the snapcraft store has only the .92-nd ones.

That is what I have tried. The errors as a result are listed above. They result from running ./configure in the sources directory.

sudo dnf install gc-devel

1 Like

Was this dropped in the newer versions? I see Fedora 31 has the beta release for version 1?

https://src.fedoraproject.org/rpms/inkscape

See “Build-essentials” package for Fedora (Unix StackExchange) if gc-devel will be not enough.

It did not work with gc-devel. I tried all the suggests on Unix SE link
dnf install @development-tools
dnf groupinstall "Development Tools" "Development Libraries"
dnf install make automake gcc gcc-c++ kernel-devel
dnf group install "C Development Tools and Libraries"

But none seems to help. The error after running ./configure on the 0.91 source directory remains same-

configure: error: Package requirements (bdw-gc >= 7.1
cairo >= 1.10
cairomm-1.0 >= 1.9.8
glib-2.0 >= 2.28
glibmm-2.4 >= 2.28
giomm-2.4
gsl
gthread-2.0 >= 2.0
libpng >= 1.2
libxml-2.0 >= 2.6.11
libxslt >= 1.0.15
pango >= 1.24
pangoft2 >= 1.24
sigc++-2.0 >= 2.0.12
) were not met:

Is there something I am missing?

I’m still trying to understand why we’re building from source. Do you need the older version?

A plagin:
“0.91 … as it has native support for one of the plugins I need to use.”


PS:  Why quote aren’t counted (“it should be at least 20 chars long”)?

Sure, but does version 1 not have this?

Yes, I need the older version as one of the plugins (sozi) works natively only till 0.9. Right now it is a stand-alone app. The 0.92 and 1.0 alpha version don’t support the said plugin natively.
Edit:
I had asked this on Inkscape forums:
https://inkscape.org/forums/beyond/using-sozi-inside-inkscape-natively/

Ah, OK.

Here’s a simpler way of installing all the build-depencies for inkscape:

sudo dnf builddep inkscape

This works for packages in the repositories: dnf can find what their “BuildRequires” are and install them. You can also refer to the inkscape spec file in Fedora for further information on how to build it from source. The last version of the spec file for version 0.92 seems to be this:

https://src.fedoraproject.org/rpms/inkscape/blob/1ddaf8ed963a2dd14b3b39f97a85bc18e5d7e0cf/f/inkscape.spec


OH! WAIT!! Just grab the 0.92 build for F31 from the Koji build system and install that. It hasn’t been deleted yet:

https://koji.fedoraproject.org/koji/buildinfo?buildID=1327007

Remember to not upgrade inkscape after this. This will help with that:

https://docs.fedoraproject.org/en-US/quick-docs/dnf/#exclude-package

2 Likes

Even dnf downgrade inkscape takes it back to 0.92 here on my F32 system. Not sure if that applies to F31 also.

1 Like

I would need 0.91, not 0.92.
The 0.92 is still in the repo and dnf --showduplicates list inkscape has it, the trouble is 0.91 is not to be found.

I was looking for a solution where I can install 0.91 alongside the 1.0 alpha, is there anyway to achieve this?

And as a last resors:  Their HowTo for .zip sources (InkScape).
(Avoid make's -j8, though – if it’s not a 8-cores machine).

1 Like

Uh, 0.91 hasn’t been in Fedora since Fedora 25:
https://koji.fedoraproject.org/koji/packageinfo?buildStart=100&packageID=2118&buildOrder=-completion_time&tagOrder=name&tagStart=0#buildlist

So, if building from source is the only solution, use dnf builddep inkscape and follow the instructions that @vits95 has linked to. The Fedora spec file for 0.91 also uses cmake, so these instructions should apply correctly.