Installing Nvidia Drivers on Fedora 34

I used the following method to successfully install Nvidia driver on Fedora 34

1. Enable RPM Fusion (Free and Non-Free Repositories)
https://docs.fedoraproject.org/en-US/quick-docs/setup_rpmfusion/

Free repository:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

Nonfree repository:

sudo dnf install https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

sudo dnf -y update

2. Install Nvidia Driver and Cuda Support

sudo dnf -y install kmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda

3. Reboot the system
sudo reboot

kmod-nvidia is for redhat centos etc. systems
fedora uses akmod-nvidia

1 Like

Please use this NVIDIA Auto Installer for Fedora now works with Fedora 34.

4 Likes

I read this comment AFTER I already quickly copy / pasted everything without thinking. How do I uninstall the commands pasted above? I just re-copy/pasted the commands above “install” with “remove” – is that correct?

I’m going to visit the link you just started and copy / paste that stuff right now. Thanks!!

You only need to do a “dnf erase kmod-nvidia”, followed by using the installer posted by t0xic0der above. That should fix everything for you.

2 Likes

Thanks, @computersavvy.

@fedora420, the installer tool (as of now) does not provide a way to uninstall and clean up the packages but you could execute the command that @computersavvy provided to do that.

As of 09/2021 this method does not work.

After reboot, nouveau did not get disabled despite having the line

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 "

in /etc/default/grub, rendering the system basically unusable.

I found this guide helpful and functional to install the legacy drivers.
https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

https://rpmfusion.org/Howto/NVIDIA?highlight=(\bCategoryHowto\b)

sudo dnf update -y # and reboot if you are not on the latest kernel
sudo dnf install akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support

comment “WaylandEnable=false” in /etc/gdm/custom.conf

Note that if you want to use the absolute latest nVidia drivers (currently 515) you need to install them from the Latest/Beta section here: Howto/NVIDIA - RPM Fusion.

Found this on this reddit thread here: https://www.reddit.com/r/Fedora/comments/vmwfbt/is_there_any_way_to_have_more_uptodate_nvidia/