Intel advisory drivers above version 5.0 should be installed

I am running OS Fedora 30 Thirty Kernel: x86_64 Linux 5.0.16-300.fc30.x86_64
Resolution: 3840x2160
DE: XFCE4
CPU: Intel Core i7-8559U @ 8x 4.5GHz [-263.2°C]
Graphics: Device-1: Intel Iris Plus Graphics 655 driver: i915 v: kernel bus ID: 00:0.0 chip ID:
Display: x11 server: Fedora Project X.org 1.20.4 driver: intel resolution: 3840x2160~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT3) v: 4.5 Mesa 19.0.4 compat-v: 3.0
direct render: Yes

As per Intel advisory drivers above version 5.0 should be installed.

How to achieve this?

I’m not an expert.
But it is stated that: “i915 Graphics for Linux before version 5.0 may allow an authenticated user to potentially enable escalation of privilege via local access” and “Intel recommends that users of Intel® i915 Graphics for Linux update to version 5.0 or later”.
You have 5.0.16, so you should be fine.

For reference: https://bugzilla.redhat.com/show_bug.cgi?id=1710405

1 Like

Yes, I know I am running kernel version 5.0.16-300.fc30.x86_64.

But is the kernel version equal to the Intel graphics driver version? Shouldn’t we differentiate this? I don’t know.

Looking for what is installed as graphic driver with tool “inxi -xxx -G” I only get special info

  • Device-1: Intel Iris Plus Graphics 655 driver: i915 v: kernel …
    “v: kernel” does this mean graphic driver version accords to kernel version?

Please take a look at the bug that @alciregi linked to. That should answer your question.

1 Like

It exists a nice, little app to view all details about GPU called GPU-Viewer on dl.flathub.org.
There in driver version is 18.3.6 for IGP. Kernel version may not correspond to driver version/numbering.