Internal mic stops working when connecting external headphones

Situation:

On my laptop, the sound captured by the internal mic (Lenovo Yoga 2 Pro) is excellent. However, the speakers are not great. So in (video) calls, I want to use my external headset (which also has a mic - but a bad one) for listening.

Problem:
Once I connect my external headset in the 3.5 audio jack, Gnome’s settings removes my internal mic as a possible input device (it’s simply not there in the drop down list). How to use my internal mic even when my external headset is connected?

In pavucontrol (screenshot), I can still see my internal mic but it is marked as “unplugged” and it does work when I select it there.

So in technical terms, I guess, how can I make Fedora not “unplug” the internal mic once I connect an external one? (I understand this use case is less common, but still…)

Research update 1:
This was also asked 5 years ago but also then without a working solution: debian - Changing PulseAudio Source port: 'availability=no' and priority - Unix & Linux Stack Exchange

Research update 2:

This change in /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf does make
Internal Microphone and not Internal Microphone (unplugged) appear in pavucontrol. However, when I select it, it will not capture any sound at all anyway.

[Jack Mic]
- state.plugged = no
+ state.plugged = yes

Plugin your headset run ‘alsamixer’ in terminal and with F6 select default sound card (in my case it is intel )


once you select you will need to with F5 to show all inputs for your card

You need to select internal mic on right side and with up arrow to from keyboard volume increase. After that check options to select your internal mic
Screenshot from 2022-05-09 22-59-34

Thanks, increasing the level in alsamixer did not change the “unplugged” status shown in pavucontrol and it did not appear in Gnome’s setting’s either.

This was also asked 5 years ago but also then without a working: debian - Changing PulseAudio Source port: 'availability=no' and priority - Unix & Linux Stack Exchange

I would expect this is part of the same software/hardware switching that occurs when you plug in the headphone. If you are using the audio jack it is likely that it has a physical switch to shift from speakers to headphones and that switch also switches the mic the same way.

Others may be able to assist in a work-around, but it seems an expected condition to me. Gamers especially would want that switch to occur.