Internet not working on fedora 34 properly

I have been using fedora 34 for a week now. But today morning when I booted and Searched on something on brave browser the it gave error “too late to respond”. Then I tried opening several websites on brave and Firefox.
Everything is working fine on my mobile phone whose hotspot I’m using for WiFi and when I use usb tethering everything works fine.
It’s only when I connect with WiFi this weird issue occurs.
I’ve noticed following things while my laptop is connected to the mobile hotspot through WiFi:
I can open Coursera and watch lectures. I can open duckduckgo and search as usual.
A bunch of websites are working fine but most of them are not. Google is not working. And any other website is also not working. Browser gives error :
“Too long to respond
ERR_TIME_OUT”.
I can download files from telegram(APP) but cannot log in into Microsoft teams(APP).
I’m clueless regarding what can be the issue.
Please help!

1 Like

Where does the error “too late to respond” appear? Is it in a browser window or some other pop-up?

2 Likes

Yes in the browser.
ask.fedoraproject.org took too long to respond
ERR_TIMED_OUT”

This comes for most of the website and only a few websites are working.
Also I’ve found that this issue is with WiFi. When I connected using USB Tethering this issue was not there and everything was working fine.

1 Like

If it is a WIFI issue, it should affect all websites.

When your college website is working, are you accessing it within your college or from outside?

When you use USB Tethering, you are using another ISP.

Any channce you need to setup some kind of Proxy when you are using your college WIFI?

You can try doing some speedtest using popular test sites like
Speed test - how fast is your internet? | DSLReports, ISP Information to see if the issue is site specific or not.

1 Like

Sounds like you have not enabled TCP MSS clamping on the router.
Make sure the problem is not with the router or the ISP behind the router.

1 Like

Only the home page of college website opens nothing else. I can open Coursera and watch lectures. I can open duckduckgo and search as usual.
A bunch of websites are working fine but most of them are not.

Everything is working fine on my mobile phone whose hotspot I’m using for WiFi and when I use usb tethering everything works fine.

It’s only when I connect with WiFi this weird issue occurs.

2 Likes

I’m using mobile hotspot.
Everything is working fine on my mobile phone whose hotspot I’m using for WiFi and when I use usb tethering everything works fine.

I don’t know if the settings you are mentioning exist for mobile hotspot.

Basically you are dealing with a noob.

1 Like

Issue is solved. It was not related to Fedora at all. I restarted my phone and received access point names from ISP after installing those configurations, everything is working fine now.
But I do not understand why was everything working when i was connecting through usb tethering but not from wifi.

2 Likes

Just want to make sure I understand your situation correctly:

  1. Using the same WIFI Hotspot, everything is working fine using your Mobile phone, while it is problematic using your computer.

  2. Using your computer, with USB Tethering to your Mobile phone, everything is working fine.

Am I correct?

1 Like

Yes, you are correct but issue is apparently solved but installing configurations provided by ISP.

2 Likes

I am glad to hear that your issue is resolved.

Mobile phone is like a black box, it is hard to the internals.

1 Like

Your first point have was not correct regarding the situation.
The hotspot was of the mobile and everything was working fine on that mobile whose hostpot was on. But not on laptop when connected through wifi only.

2 Likes

yes,
And I really appreciate your support. I was going to install fedora again but because of the replies I thought that issue can be solved.
Thanks a lot.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.