Is Conky dead? Does not seem to work properly on Fedora 33

Hi. As the title says, it seems to me Conky does not work any longer on Fedora 33. I have being using it since fedora 31 with no issues, but now Conky Manager fails to launch any widget and conky itself just launch a widget that I found no way to modify. I searched about this but found no direct answers. Any ideas how to fix it?

This information is not enough, please give us more information:

you can execute in terminal, and share with us the error did you get:

conky-manager

or

conky -c  .conkyrc      # conky config file

and see what error did you get on terminal.

Regards.,

1 Like

Thanks so much. This is what I get with both commands:

[francisco@localhost ~]$ conky-manager
[10:43:23] Desktop: gnome
[10:43:23] Found theme pack [installed]: /usr/share/conky-manager/themepacks/default-themes-2.1.cmtp.7z
[10:43:23] App config loaded: '/home/francisco/.config/conky-manager.json'
[10:43:24] Searching for conkyrc files... 12 found
conky: Syntax error (/home/francisco/.conky/TeejeeTech/NVIDIA Panel:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/Network Panel:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/Green Apple Desktop/Gotham:1: syntax error near 'yes') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
[10:44:06] App config saved: '/home/francisco/.config/conky-manager.json'

[francisco@localhost ~]$ conky -c  .conkyrc      # conky config file
conky: cannot open .conkyrc: No such file or directory
[francisco@localhost ~]$ ^C
[francisco@localhost ~]$

@boricua Have you tried stripping the .conkyrc down to the defaults? Given the error messages, it might not be a bad place to start. You could always rename your .conky directory and start at the basics from there.

1 Like

I suggest to you, make a backup of your conky config directory:

some of your conky config file has a bad syntax which affect to a new release… and find a up-to-date conky config file… or review it…

mv .conky/ .conky-old/

and tried to start conky-manager again…

Regards.,

2 Likes

Thanks for the suggestions. I tried both approaches but neither work. The syntax error is present in each widget launch:

[francisco@localhost ~]$ conky-manager
[14:59:20] Desktop: gnome
[14:59:20] Found theme pack [installed]: /usr/share/conky-manager/themepacks/default-themes-2.1.cmtp.7z
[14:59:20] App config loaded: '/home/francisco/.config/conky-manager.json'
[14:59:20] Searching for conkyrc files... 12 found
conky: Syntax error (/home/francisco/.conky/Conky MIUI/miui:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/Conky Seamod/conky_seamod:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/Gotham/Gotham:1: syntax error near 'yes') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/Green Apple Desktop/Gotham:1: syntax error near 'yes') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/CPU Panel (2-core):2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/CPU Panel (6-core):2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/CPU Panel (8-core):2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/Network Panel:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/Process Panel:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/NVIDIA Panel:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/TeejeeTech/CPU Panel (4-core):2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
conky: Syntax error (/home/francisco/.conky/Green Apple Desktop/conky_seamod:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
[15:00:31] App config saved: '/home/francisco/.config/conky-manager.json'
[francisco@localhost ~]$

It has been a while since I’ve used conky. I’m going to assume that you’re using hash marks for comments based on the output you’ve provided? That changed several years back. Comments now look like this:

-- this is a comment
That is 2 dashes, a space and the text

A block of comments could look like this:

    --[[
    comment
    comment
    comment
    ]]

Might be worth looking into?

1 Like

Thanks. I will try to look at it.

this is what you have to do:

give some review:

Actually, it’s quite easy:

* wrap your config section in
* conky.config = { ... }
* wrap your TEXT section in
* conky.text = [[ ... ]]
* the config options are lookup values and you need to assign the values (i.e. use "=")
* each line in the config section ends with ","
* replace "yes" and "no" with "true" and "false", resp. (without quotes)
* all values except numbers, "true" and "false" need quotes
* comments are marked with "--" instead of "#"

Conky will works well after rewrite conky with the new syntax.

Note

command to see your version:

conky --version

Regards.,

Hi again,
Conky version is “conky 1.11.6_pre compiled Tue Jul 28 07:43:46 UTC 2020 for Linux 5.6.15-300.fc32.x86_64 x86_64”
I am able to run conky’s generic widget. However, the ones controlled via conky-manager are the problem. I have no .conkyrc file installed in my Home directory, so I suppose that’s the root of my problem. I probably screwed up my config files by migrating them back from a backup directory, after doing a F33 clean install.

It does appear there are some issues with using other conky widgets beyond the default one. I settled for the default config file and will not use conky-manager for F33. I will then add - very carefully - new info sources to the default conky widget config file. Thank you for your attention and support.

I don’t know if I would call it “dead”, “broken” maybe.

Conky has two packages for fedora: Conky and Conky-Manager.

When you run the first one, the widget appears on the desktop, but you can only modify it via the text file /etc/conky/conky.conf.

And that can take hours (like me) depending on your experience doing so, so let’s go with Conky-Manager.

It opens with no problem but if you check a widget, this one doesn’t show on the desktop. Using the shell to open conky-manager shows the “syntax error near #” thing, a solution for that is using convert.lua script provided by nice people on GitHub.

The script works, but after closing and re-open Conky-Manager the widgets that you modify with the script disappear from the list, like the image below.

Even if the widgets doesn’t disappear from the list, as soon as you modify them with the tool button they will be gone from desktop 'cause Conky-Manager will still use “#” instead of “–” or " yes" instead of " = true," and more more… This one was reported on Bugzilla.

The only thing I could think of was on using the first package (conky) and modify the generic widget vía the text file /etc/conky/conky.conf. So I did, it took me hours and I’m still learning,

But (for me) this is the funny part, after a couple of hours, modifying it, between yesterday and today I came to realize that if I clic on a free space of the desktop the generic widget disappear automatically.

XD

Also, I don’t know if is just me but I still can’t find anywhere that file that everyone call .conkyrc.

I have a virtual-machine with Fedora 32 and there everything seems just fine with conky and conky-manager.

Conky has some time in the wild forest by now, but just yestarday I wanted to start using it for the first time. That’s how I get to your question @boricua.

Just in case, I use Fedora 33 XFCE spin.

Thanks for reading.

Thanks for sharing. I am using the generic conky script and modified it to look just more or less like yours. As I recall from my search, I copied the file conky.conf from /etc/conky into my /home directory and saved it as a hidden file named .conkyrc. So, I invoke conky directly from my modified .conkyrc file in /home, avoiding using the original conky.conf file, and edited it accordingly to suit my tastes, specially transparency.

@boricua I’m willing to bet the problem is not Fedora but the version of conky you are using.

conky 1.11.6_pre is known for having regression issues. Try downgrading to the prior version 1.11.5_pre by running the command:

dnf downgrade conky

I am on F32 and my conky setup started breaking once I upgraded to 1.11.6

If downgrading the version indeed fixes your problem, you have to make sure you don’t upgrade conky again. Whenever you update your system going forward, you have to tell dnf not to update conky by running the command:

sudo dnf update -x conky

Thanks for the input @ernesto10. Tried but it’s already too late to downgrade. Further, I tweaked the conky.conf file enough to suit my needs. I will now wait for F34 to see what hapens.

So, Conky is not dead… it’s alive and well. What you may have missed, however, many other posts have referred to. It updated several years ago and Fedora has implemented those changes since Fedora 29. A great resource for you can be found at conky/convert.lua at main · brndnmtthws/conky · GitHub. This script will convert your favorite old conky files to the current version (used in most modern distros [ie Fedora, Ubuntu 20.10, Arch, Manjaro, etc]). The conky manager can be used to select the conky scripts that you have converted but it doesn’t work as well as it used to. That’s why the good folks at Debian have created a fork called “Conky Manager 2.” You can download the source and build the program yourself (or install alien and convert the .deb file). I don’t use it because it is cumbersome, you can edit the conky-startup.sh file much easier than installing that GUI software, but to each their own. I hope I helped.

Thanks for the info. I gave up trying converting the files and settled with the default Conky file. I intend to try again with Fedora 34.