Is there a way to improve Cantarell font in Linux fedora 32

I have noticed for some time now that Evernote web client in chrome browser use in the left section, “All notes section” a very thin font, you can hardly see it.

Information

  • Cantarell
  • font-size: 14px;
  • font-weight: 300 (cantarell-light)
  • color: #737373
  • font-family: …, Roboto, …, Cantarel, …;

In fedora what can we do for fix that issue?
On windows the font rendering is a little bit better, but the problem persists.
I don’t understand why doesn’t used Roboto instead of Cantarell, even though Roboto it’s in the first place as you can see in the third image below in the font-family property used by the Evernote website.

Screenshot from 2020-08-03 19-33-58

Screenshot from 2020-08-03 19-33-47

Screenshot from 2020-08-03 20-54-57

Hello @christian1: question, is Roboto in your fonts? You could use Fonts app.

Looks like you’re using Chrome (or at least a Chromium-based browser), and you’re looking at DevTools so you must know some web dev stuff. Install the Stylus extension and just go ahead and adjust the CSS to your liking.

As for system font rendering, it was the only thing that bothered me about Fedora until I found this COPR. It includes adjustments for font rendering as well as some font replacements. Of course anything you don’t like can be overwritten by your own fontconfig.

Hope this helps.

2 Likes

Personally, I use Google Noto fonts from the official Fedora repos specifically for Chromium.

ok, I was wrong, was thinking the font was there along Cantarell and the others.

hello pal, google-noto-sans-cjk-ttc-fonts.noarch is installed, now what is the next step?, thanks in advance.
Update: ok modify the fontconfig of my Linux distribution.

1 Like

Ok, There are 2 entries for catarell-light.

In a side by side comparison , yes “Noto Sans CJK HK, Light” is tiny darker.

can we modify the fallback font order in fontconfig?
How can we easy use “Noto Sans CJK HK” instead of “Cantarell”?

1 Like

I install the following packages:

sudo dnf install \
google-noto-emoji-color-fonts \
google-noto-emoji-fonts \
google-noto-sans-fonts \
google-noto-sans-mono-fonts \
google-noto-serif-fonts

Then, go to Chromium chrome://settings/fonts and select the Noto fonts.

1 Like