Isolinux.bin missing or corrupt

After creation of f31 using fedora writer to USB and changing the BIOS boot sequence to make the removable as 1st I got the following error.
isolinux.bin missing or corrupt

Is these something related to PC settings? I have windows10 already installed because on a PC having ubuntu it worked and showed the installation window!

Test this USB with fsck, please. Probably it was corrupted when the stick was removed from the computer.

Stupid question: does your PC support 64 bit operating systems?

Edited. I added the colons in order to identify what is the stupid question.

2 Likes

Link. Are your BIOS has any “USB mode” settings, or such?

Please, see section BUGS in man 1 syslinux.

Why stupid question!

1 Like

Sorry @rtarik for the confusion.
Does your PC support 64 bit operating systems? <-- this is the stupid question, and not your question

No problem, yes it does.

I mentioned it worked on ubuntu machine?

What about “now”: This USB works on Ubuntu machine now?

Yes, your're mentioned

But it didn’t worked on this machine. So the links. The devs of syslinux (includes isolinux) rant about hardware-related troubles, and BIOS-related troubles.

Internet didn’t bring any answers to me, but:

  1. try different USB ports
  2. remove most USB devices during boot time,

and the other magic.

Fedora installation x86_64 ISOs use GRUB as the bootloader on computers with UEFI firmware, and isolinux (variant of syslinux) on computeres with BIOS firmware. My suggestion is to confirm whether the computer really is UEFI or BIOS; in particular you need to discover if you have a UEFI installation of Windows 10 or if it’s a BIOS installation of Windows 10.

Make certain Fedora is installed using the same firmware mode as the Windows 10 installation. This is committed at Fedora installation time, just like the Windows installer. That is, if you boot the installer in BIOS mode, you get a BIOS installation. If you boot the installer in UEFI mode, you get a UEFI installation.

If you determine that you should do a BIOS mode installation, I suggest trusting that the error may be correct, and just recreate the USB install media, possibly using alternate USB media.

2 Likes

Have not seen any updates for 3 days, but I wonder if his bios is set to compatibility mode (sometimes referred to as CSM mode).
On some systems compatibility mode will boot for a new install in BIOS mode even if the windows OS is already installed and booting in UEFI mode.

I have solved that problem by setting the bios to use only UEFI, then the install will match the current configuration.

Yep. Sometimes the firmware setup UI calls it legacy boot. Others call it, absurdly, “UEFI disabled”

It’s virtually certain UEFI because anything that comes with Windows 10 is UEFI.

An unambiguous way to tell, is the drive GPT or MBR partitioned? Windows on UEFI uses GPT, and BIOS (or UEFI with CSM) uses MBR partitioning.

1 Like


don’t want to test it on ubuntu machine now, it has some problems.

The windows 10 machine has this:


f-31 test live:

Enter MS-7358 here (MEDION service: drivers, updates, and manuals).

Your may wish to contact them as well.  Really, all of this is a “hairy” thing.  I’m personally have no other ideas for now.

1 Like

You can try the 3 option indicated here: related with “Emulation Type” I think it can be your problem in the case you did verified the media. Check the link.

If you did solve the issue and if you after wish install fedora, look up for your windows install like @chrismurphy well pointed you. Your screen captures show that W10 is installed in Legacy/Bios mode so that you don’t should install in UEFI mode because you will can not boot in windows after.

Regards.

1 Like