Issue Fedora 31 GTX 1660ti Dell G3

Hello,

I installed Fedora 31 on a new laptop Dell G3. I also installed Nvidia drivers from https://rpmfusion.org/Howto/NVIDIA.

When I check about on my system it works but now I can only use HDMI monitor. No other devices are detected (the laptop screen is not detected anymore).

When I use another tty (console), it’s the laptop screen who works.

If I remove the /etc/X11/xorg.conf, the HDMI is not working anymore and Fedora use the intel chipset.
Content of /etc/X11/xorg.conf :

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
EndSection

$ sudo lsmod | grep nouveau|nvidia
==> Nothing appear

$ sudo cat /etc/grub2.cfg | grep nouveau
set default_kernelopts= … rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 …"

Same with cat /etc/grub2-efi.cfg | grep nouveau

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm

What do you think I missed ?
Thanks a lot in advance.

Is that optimus technology you have there?
What do you get from the following command?

lspci | grep VGA

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)

That’s optimus technology alright.
DId you follow the instructions on this page? Which version of the driver did you install?

I followed the same instructions, the driver version is 440:

$ rpm -qa | grep nvidia
kmod-nvidia-5.5.13-200.fc31.x86_64-440.64-1.fc31.x86_64
xorg-x11-drv-nvidia-cuda-440.64-2.fc31.x86_64
nvidia-persistenced-440.64-1.fc31.x86_64
xorg-x11-drv-nvidia-kmodsrc-440.64-2.fc31.x86_64
nvidia-xconfig-440.64-1.fc31.x86_64
xorg-x11-drv-nvidia-cuda-libs-440.64-2.fc31.x86_64
akmod-nvidia-440.64-1.fc31.x86_64
xorg-x11-drv-nvidia-440.64-2.fc31.x86_64
nvidia-settings-440.64-1.fc31.x86_64
xorg-x11-drv-nvidia-libs-440.64-2.fc31.x86_64

My kernel is :

$ uname -r
5.5.13-200.fc31.x86_64

I uninstalled everything and clean before retrying. Now it’s working.
Things I made differently is adding support for Optimus.

Thanks

1 Like

Awesome. I am glad it work out. Enjoy Fedora

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.