Issue updating machine fedora 32 to fedora 33 or 34

,

After some research for installing PostgreSQL database; I see I need to update fedora on my machine. I didn’t know I needed an update, usually KDE does a pretty good job informing me about machine updates. I know now that Fedora 32 is out of date and I should update. Problem is is that I have followed the instructions from the fedora docs page and when I run the system update reboot command I first get a screen saying, “Do not turn off machine update in progress” with a progress bar stuck at 0%. Then I am in launched to my login screen for Fedora 32. Please let me know if more information needs to be provided. Thanks

It is not clear which docs page You followed. This DNF System Upgrade one?

Welcome to ask.:fedora:edora @py4life

If you not had time yet please read first #start-here. So you see what kind of information we need without telling you every step.

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Similar problem was on this topic, please go thru and see where others struggled.

1 Like

Yes I followed the DNF System Upgrade one. I even tried the Gnome software center update and my system still does not update.

Thanks. I’ve tried a lot of these already but I must of missed this one. I’ll give it a try and print my discoveries.

sudo dnf --releasever=3x distro-sync I guess the distro-sync is not mentioned in the manual.
You might try this ?!

1 Like

so the steps that I should try are:

sudo dnf upgrade --refresh

sudo dnf install dnf-plugin-system-upgrade

sudo dnf --releaseserver=34 distro-sync

sudo dnf system-upgrade reboot

So i did get some feedback with the command you suggested:

Error:
Problem: problem with installed package fedora-release-common-32-4.noarch

  • package generic-release-common-34-0.1.noarch conflicts with fedora-release-common provided by fedora-release-common-34-39.noarch
  • package generic-release-common-34-0.1.noarch conflicts with fedora-release-common provided by fedora-release-common-34-1.noarch
  • package nodesource-release-fc32-1.noarch requires redhat-release >= fc32, but none of the providers can be installed
  • fedora-release-common-32-4.noarch does not belong to a distupgrade repository
  • problem with installed package nodesource-release-fc32-1.noarch

should I use --skipbroken or --allowerasing? Or is there a different approach entirely?

Update did some research and I added --allowerasing, now I am getting the downloading process to start

After

sudo dnf --releaseserver=34 distro-sync --allowerasing

I got the following during the transaction check:
Running transaction
Running scriptlet: filesystem-3.14-5.fc34.x86_64
Running scriptlet: alsa-sof-firmware-1.9.3-1.fc34.noarch
Running scriptlet: copy-jdk-configs-4.0-1.fc34.noarch
Running scriptlet: java-11-openjdk-headless-1:11.0.13.0.8-2.fc34.x8
Running scriptlet: selinux-policy-targeted-34.25-1.fc34.noarch
Running scriptlet: npm-1:6.14.11-1.14.16.0.4.fc34.x86_64
Running scriptlet: kmail-20.12.2-1.fc34.x86_64
Running scriptlet: firefox-96.0.3-1.fc34.x86_64
Running scriptlet: java-1.8.0-openjdk-headless-1:1.8.0.322.b06-2.fc
Preparing :
Transaction couldn’t start:
file /usr/lib/node_modules/npm/docs from install of npm-1:6.14.11-1.14.16.0.4.fc34.x86_64 conflicts with file from package nodejs-2:14.19.0-1nodesource.x86_64

I would try removing the nodejs package, especially since that package is not a fedora package.

You may also be able to add --best to that command and have it work. If not then you could try --skip-broken.

By the way, with the command you are using it is not using the dnf system-upgrade path, so the final command dnf system-upgrade reboot you posted is not needed and would likely fail.

I was able to finally get it to update to Fedora 34. There are a couple things I want to highlight in this summary. @ilikelinux suggestion for distro-sync helped a bunch in isolating the error as well as helping me actaully update my system.

Steps I followed

sudo dnf upgrade --refresh

sudo dnf install dnf-plugin-system-upgrade

sudo dnf --releaseserver=34 distro-sync

sudo dnf system-upgrade reboot

After running the distro-sync step I found the error I listed about conflicting files to overcome this. After some digging to understand nodjs, I decided to remove it and I used the following command:

sudo npm uninstall -f npm
sudo dnf remove nodejs -y

That removed the file that was part of the conflicting file types error
I reran the distro-sync command I listed above but also added --allowerasing
then ran dnf system-upgrade reboot
Now my sytem is updated without any missing files and I am back in business.

other resources that may help:

Thanks again

1 Like