Issue with upgrading libicu

Hi,

Running dnf update gives me the following error:

Problem 1: cannot install both libicu-65.1-1.module_f31+7164+9e64a937.x86_64 and libicu-63.2-3.fc31.x86_64

  • package boost-regex-1.69.0-9.fc31.x86_64 requires libicuuc.so.63()(64bit), but none of the providers can be installed
  • package boost-regex-1.69.0-9.fc31.x86_64 requires libicudata.so.63()(64bit), but none of the providers can be installed
  • package boost-regex-1.69.0-9.fc31.x86_64 requires libicui18n.so.63()(64bit), but none of the providers can be installed
  • cannot install the best update candidate for package libicu-63.2-3.fc31.x86_64
  • cannot install the best update candidate for package boost-regex-1.69.0-9.fc31.x86_64
  • package libicu-63.2-3.fc31.x86_64 is filtered out by modular filtering
    Problem 2: cannot install both libicu-65.1-1.module_f31+7164+9e64a937.x86_64 and libicu-63.2-3.fc31.x86_64
  • package nodejs-libs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires libicui18n.so.65()(64bit), but none of the providers can be installed
  • package nodejs-libs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires libicuuc.so.65()(64bit), but none of the providers can be installed
  • package evolution-data-server-3.34.2-1.fc31.x86_64 requires libicuuc.so.63()(64bit), but none of the providers can be installed
  • package evolution-data-server-3.34.2-1.fc31.x86_64 requires libicui18n.so.63()(64bit), but none of the providers can be installed
  • cannot install the best update candidate for package nodejs-libs-1:12.10.0-1.module_f31+6288+9325cde9.x86_64
  • cannot install the best update candidate for package evolution-data-server-3.34.2-1.fc31.x86_64
  • package libicu-63.2-3.fc31.x86_64 is filtered out by modular filtering
    Problem 3: package nodejs-libs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires libicui18n.so.65()(64bit), but none of the providers can be installed
  • package nodejs-libs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires libicuuc.so.65()(64bit), but none of the providers can be installed
  • cannot install both libicu-65.1-1.module_f31+7164+9e64a937.x86_64 and libicu-63.2-3.fc31.x86_64
  • package nodejs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires nodejs-libs(x86-64) = 1:12.13.1-1.module_f31+7164+9e64a937, but none of the providers can be installed
  • package gnustep-base-libs-1.25.0-14.fc31.x86_64 requires libicuuc.so.63()(64bit), but none of the providers can be installed
  • package gnustep-base-libs-1.25.0-14.fc31.x86_64 requires libicui18n.so.63()(64bit), but none of the providers can be installed
  • cannot install the best update candidate for package nodejs-1:12.10.0-1.module_f31+6288+9325cde9.x86_64
  • cannot install the best update candidate for package gnustep-base-libs-1.25.0-14.fc31.x86_64
  • package libicu-63.2-3.fc31.x86_64 is filtered out by modular filtering
    Problem 4: package nodejs-libs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires libicui18n.so.65()(64bit), but none of the providers can be installed
  • package nodejs-libs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires libicuuc.so.65()(64bit), but none of the providers can be installed
  • package nodejs-1:12.13.1-1.module_f31+7164+9e64a937.x86_64 requires nodejs-libs(x86-64) = 1:12.13.1-1.module_f31+7164+9e64a937, but none of the providers can be installed
  • cannot install both libicu-65.1-1.module_f31+7164+9e64a937.x86_64 and libicu-63.2-3.fc31.x86_64
  • package npm-1:6.12.1-1.12.13.1.1.module_f31+7164+9e64a937.x86_64 requires nodejs = 1:12.13.1-1.module_f31+7164+9e64a937, but none of the providers can be installed
  • package harfbuzz-icu-2.6.1-2.fc31.x86_64 requires libicuuc.so.63()(64bit), but none of the providers can be installed
  • package harfbuzz-icu-2.6.1-2.fc31.x86_64 requires libicudata.so.63()(64bit), but none of the providers can be installed
  • cannot install the best update candidate for package npm-1:6.10.3-1.12.10.0.1.module_f31+6288+9325cde9.x86_64
  • cannot install the best update candidate for package harfbuzz-icu-2.6.1-2.fc31.x86_64
  • package libicu-63.2-3.fc31.x86_64 is filtered out by modular filtering
    ================================================================================================================
    Package Architecture Version Repository Size
    ================================================================================================================
    Skipping packages with conflicts:
    (add ‘–best --allowerasing’ to command line to force their upgrade):
    libicu x86_64 65.1-1.module_f31+7164+9e64a937 updates-modular 9.6 M
    Skipping packages with broken dependencies:
    nodejs x86_64 1:12.13.1-1.module_f31+7164+9e64a937 updates-modular 413 k
    nodejs-libs x86_64 1:12.13.1-1.module_f31+7164+9e64a937 updates-modular 9.8 M
    npm x86_64 1:6.12.1-1.12.13.1.1.module_f31+7164+9e64a937 updates-modular 3.4 M

Transaction Summary

================================================================================================================
Skip 4 Packages

Nothing to do.
Complete!

This is causing other dependencies to behave unexpectedly.

I wonder if anyone could help me to resolve this issue.

Many many thanks. :slight_smile:

You have two option here:

1.- use the flag --best --allowerasing that DNF suggest to you and check the result
2.- Remove the conflict package and install later

Regards.,

That’s true but using --best --allowerasing also removes as many as 392 dependencies! :smiley:

too dangerous for continue…

your version is greater than provides from fedora repo…

How do you install it?
Did you enable any Fedora Module?

could you please provide the following information:

dnf info libicu
rpm -qa | grep module_
dnf module list --installed
dnf module list --enabled

you can also test:

sudo dnf downgrade libicu

Regards.,

2 Likes

Very helpful message. It helped me to understand the source of the issue.

The problem was that I had enable the “Fedora Modular 31 - x86-64 Updates” repository. Both libicu 65 and nodejs 12.3.1 were trying to be installed from there.

Thanks a lot for your help.

What worked for me was

dnf module reset nodejs

and then upgrade everything.
Nodejs stayed on the 12 LTS release and everything upgraded fine.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.