Issue With Vim in Latest 34 Updates

After just upgrading my servers to Fedora 34, vim is displaying an error every time it’s used.

E1187: Failed to source defaults.vim
Press ENTER or type command to continue

This isn’t a serious problem, but it is rather annoying, as it pops up every time vi/vim is run.
This only started with the latest updates, systems still running 33, or already running 34 didn’t display this behavior until updated.

2 Likes

Can you tell us the version of vim you’re using now? I just updated to the latest version on F34 and am not seeing this error:

$ rpm -qa \*vim\*
vimiv-qt-0.8.0-1.fc34.x86_64
notmuch-vim-0.32.1-2.fc34.x86_64
vim-filesystem-8.2.2956-1.fc34.noarch
vim-common-8.2.2956-1.fc34.x86_64
vim-X11-8.2.2956-1.fc34.x86_64
vim-enhanced-8.2.2956-1.fc34.x86_64
vim-minimal-8.2.2956-1.fc34.x86_64

Could you also start vim without any configurations to see if the issue persists?

vim -u NONE

If you don’t see an issue here, then it’s probably a configuration or plugin issue.

The current version appears to be vim-minimal-8.2.2956-1.fc34.x86_64.
That’s the only vi/vim package that seems to be installed.

It doesn’t occur when started without any configuration.

The solution, if anyone encounters this, is to install vim-common.

It seems that there’s some issue with these packages being overlooked by ‘dnf’ in the latest updates.

4 Likes

Hi,

Alternatively you can just create defaults.vim as symlink virc:

sudo ln -s /etc/virc /usr/share/vim/vim82/defaults.vim

Fixed it for me.

Thanks Tom.

1 Like

Thank you for reporting this issue.

I am having the same issue and it helps.

This has also been reported. Seems to be a change in upstream vim. The maintainer notes this workaround:

If anyone wants to turn off defaults.vim for vim-minimal, you can add:

let skip_defaults_vim = 1

into /etc/virc or into your personal ~/.virc.

https://bugzilla.redhat.com/show_bug.cgi?id=1969936

A fix to rawhide has been pushed, so I expect it’ll also get pushed to stable releases soon:

https://src.fedoraproject.org/rpms/vim/c/6a934f62de5b7be6af1d14174aa9049b9ea8d027?branch=rawhide

Hi,

Where does let skip_defaults_vim = 1 need adding in /etc/virc ?

I can set with with ~/.virc, but can’t seem to set globally, so having issues when using vi with sudo.

Thanks Tom.

1 Like