Issues with fresh Fedora installation: software says "file not supported" and others

Good Evening,

I installed Fedora 30 as a first-time user on my Sony Vaio SXF1521K6E from a USB stick. I then understood that I needed to install rpmfusion-free and/or rpmfusion-nonfree (from USB stick) for Fedora to detect my Broadcom BCM43142 and/or Tp-link USB so as to get wireless. On double-clicking either rpm file I received the message file not supported (within Software). So, I tried from within Terminal as a root user, but the rpms wouldn’t install unless I disabled other repo files, namely; fedora-modular, fedora-updates, updates and fedora. After “successful” installation I added and enabled as stated here^ but neither my pci nor usb (both for wireless) were detected afterwards (even on reboot). Before (with no disabled repos) I did try zchunk=false though it was not in my dnf-conf file. I also tried the zchunk patch anyway (had to disable aforementioned repos) but to no avail. ifconfig reports that both Broadcom and Tp-link are UP; iwconfig reports no wireless extensions for the Broadcom pci. With the repos disabled I cannot install DraftSight, with the repos enabled I get the file not supported fail message.

https://docs.fedoraproject.org/en-US/quick-docs/adding-or-removing-software-repositories-in-fedora/

Here’s hoping that some can help!
P.S. This is from a fresh installation with nothing else installed (and re-installed x3)

Hello @medfed—welcome to the community! Please take a look at the posts in the #start-here category if you haven’t already. They summarise information on how to get the best out of this platform.

Now, your issue seems to be very weird–certainly not one we’ve seen here yet. Without the exact errors that you’ve received, it’s quite hard to debug it. So. Could we have some information on your system to begin with please?

  • cat /etc/os-release -> tells us the Fedora installation and other information on it.
  • could you link us to the page where you found the rpmfusion repositories also please?
  • since if you are still experiencing the issues, can you please copy the errors and paste them here for us to look at? For the “file not supported” error, a screenshot would be very helpful too.

Cheers!

PS: I edited the topic to make it more informative. That makes it more likely for other community members to chime in also.

Hi FranciscoD,
Thanks for helping

Link to page:
https://rpmfusion.org/Configuration
I’m beginning to see that the error is mine and it’s here; these rpms must run from Firefox within Fedora. Oh fiddlesticks! I’m sorry I missed that, FranciscoD

cat /etc/os-release: Had to do a screenshot because copy is greyed out. I cannot post it yet as I’m only allowed one upload per post. Do let me know whether you’d like me to included it in the next post.

On double-clicking the downloaded repo files:
Unable to contact “extension.gnome.org
Unable to contact “admin.fedoraproject.org
Failed to install file: not supported
Screenshot%20from%202019-05-27%2021-17-13

using

cat /etc/os-release |fpaste

the output of the command will be uploaded to https://paste.fedoraproject.org/
The porvided link can you paste here.

Thanks nevermore,

but my problem is that I haven’t yet got an internet connect on Fedora

I’ve marked your reply as correct, but I don’t think I still understand the issue :laughing:
What do you mean by “rpms must be run from Firefox within Fedora”? Where you running them on another system?

How did you try to copy the text? Did you select/highlight it? That should enable the “copy” option when you right click.

I’m not running them but did download them on another machine. I can see now that I’d need to open https://rpmfusion.org/Configuration on my Sony which uses Fedora, and then click the appropriate link under Graphical Setup via Firefox. But I cannot do this yet because I do not have internet access on the Sony. That’s my problem. Right now I am on the other laptop which uses Windows and Firefox. I thought that I could download the appropriate rpms and transfer them to the Sony via USB stick. But this has not worked out. Is it at all possible to do this? I cannot use the LAN here because it’s PQE. Actually, strike that, I can use LAN on a PQE router, it just that I get the same Activation of Network connection failed message

I haven’t figured out select/highlight yet, but I just learned to used Shift and the left button…

Cat /etc/os-release:


[useru@localhost ~]$ cat /etc/os-release
NAME=Fedora
VERSION="30 (Workstation Edition)"
ID=fedora
VERSION_ID=30
VERSION_CODENAME=""
PLATFORM_ID="platform:f30"
PRETTY_NAME="Fedora 30 (Workstation Edition)"
ANSI_COLOR="0;34"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:30"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f30/system-administrators-guide/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=30
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=30
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Workstation Edition"
VARIANT_ID=workstation
[useru@localhost ~]$

Ok, I see Select All in the Edit menu

Yes, that should be fine. Download the rpm files, and copy them over to the required machine, and use this command in a terminal:

sudo dnf install <path/to/rpms>

But again, even if you have rpmfusion set up, you still need internet connectivity to install packages from the repos.

This happened to me too, I had to re-install fedora. The only thing I could see as the problem, was that the first time I didn’t run dnf upgrade after the installation, but first I installed another repos/plugins/packages. The second time, I first run dnf upgrade, reboot and keep installing other stuff.

Also, if you are seeing timeouts when installing a gnome extension, maybe this could help Error while installing gnome-shell-extensions due to missing `unzip` command on a freshly installed system

Good Morning FranciscoD,

But that’s what I did at the first. Well, after trying at GUI level which returned the file: not supported message.I’m supposing that this particular error is generated due to the failure of accessing the two URLs?


[useru@localhost ~]$ cd /
[useru@localhost /]$ sudo bash
[sudo] password for useru: 
[root@localhost /]# dnf install /home/useru/Downloads/rpmfusion-free-release.rpmFedora Modular 30 - x86_64                      0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'fedora-modular'
Error: Failed to synchronize cache for repo 'fedora-modular'
[root@localhost /]# dnf config-manager --set-disable fedora-modular
[root@localhost /]# dnf install /home/useru/Downloads/rpmfusion-free-release.rpm
Fedora Modular 30 - x86_64 - Updates            0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'updates-modular'
Error: Failed to synchronize cache for repo 'updates-modular'
[root@localhost /]# dnf config-manager --set-disable updates-modular
[root@localhost /]# dnf install /home/useru/Downloads/rpmfusion-free-release.rpm
Fedora 30 - x86_64 - Updates                    0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'updates'
Error: Failed to synchronize cache for repo 'updates'
[root@localhost /]# dnf config-manager --set-disable updates
[root@localhost /]# dnf install /home/useru/Downloads/rpmfusion-free-release.rpm
Fedora 30 - x86_64                              0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'fedora'
Error: Failed to synchronize cache for repo 'fedora'
[root@localhost /]# dnf config-manager --set-disable fedora
[root@localhost /]# dnf install /home/useru/Downloads/rpmfusion-free-release.rpm

Now the rpms will load at this stage but, I’m supposing, not really successfully (they are present in the etc/yum.repos.d folder). Or does this mean that they have loaded successfully?

Therefore, my Broadcom and tp-link drivers are not stored locally within these repo files but are on a server?

By the way my LAN returns the same Activation of network connection failed message as when my tp-link wireless (USB) was at least trying.; the LAN on my Windows-installed laptop is disabled because it’s faulty, so I cannot link it to my Fedora-installed laptop.

So, what of someone who simply cannot access the internet but wants to install non-propriety wireless driver files?

Thanks stsewd,

But it appears that my problem is that I cannot get an internet connection at all on my Fedora-installed laptop in order to get anywhere.

You need to download rpm:

http://mirror.math.princeton.edu/pub/rpmfusion/nonfree/fedora/releases/30/Everything/x86_64/os/Packages/b/broadcom-wl-6.30.223.271-10.fc30.noarch.rpm

and save with to your Downloads directory. After that with terminal

  • cd Downloads – go to Downloads directory
  • run ’ sudo dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm’
  • reboot
  • see if is wireless network pick up

dependencies:

No, repo configuration packages are exactly that—configuration files that tell dnf etc. where to fetch packages from. The fedora repositories are in the order of 100s of Gigs, and RPMFusion would be in the 10s too. So, all of these packages are not downloaded on systems. The tools simply fetch the ones that are needed.

This is something that can be debugged. Can you please open a separate topic with details on what this issue is?

To install any software, whether from Fedora or other supported repositories, you need to download it first. The easiest way is to have network connectivity. If you don’t, you need to manually download the packages on a different machine, move them over, and install them. This isn’t trivial—you need to not only download the packages, you also need to figure out their dependencies manually and download them—dnf does this for you when it fetches packages from the repos.

This may or may not work—if any deps are rquired by the broadcom-wl package, they will also need to be downloaded. PS: please use formatting tools to make posts readable. I’ve edited yours now.

Hi ledeni,

Thanks for helping; thanks for the links. Here’s my Terminal activities at the following of your directions:

[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora Modular 30 - x86_64                      0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'fedora-modular'
Error: Failed to synchronize cache for repo 'fedora-modular'
[root@localhost Downloads]# dnf config-manager --set-disable fedora-modular
[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora Modular 30 - x86_64 - Updates            0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'updates-modular'
Error: Failed to synchronize cache for repo 'updates-modular'
[root@localhost Downloads]# dnf config-manager --set-disable updates-modular
[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora 30 - x86_64 - Updates                    0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'updates'
Error: Failed to synchronize cache for repo 'updates'
[root@localhost Downloads]# dnf config-manager --set-disable updates
[root@localhost Downloads]# 

And then it installed (but I’ve somehow managed to miss the last lines)

Per the dependencies:

[root@localhost /]# dnf install akmod-wl-6.30.223.271-23.fc30.x86_64.rpm
Fedora 30 - x86_64                              0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo &apos;fedora&apos;
Error: Failed to synchronize cache for repo &apos;fedora&apos;
[root@localhost /]# dnf config-manager --set-disable fedora
[root@localhost /]# dnf install akmod-wl-6.30.223.271-23.fc30.x86_64.rpm
RPM Fusion for Fedora 30 - Free - Updates       0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo &apos;rpmfusion-free-updates&apos;
created by dnf config-manager from file:///rpmf 0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo &apos;rpmfusion-free&apos;
RPM Fusion for Fedora 30 - Nonfree - Updates    0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo &apos;rpmfusion-nonfree-updates&apos;
created by dnf config-manager from file:///rpmf 0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo &apos;rpmfusion-nonfree&apos;
Ignoring repositories: rpmfusion-free-updates, rpmfusion-free, rpmfusion-nonfree-updates, rpmfusion-nonfree
Can not load RPM file: akmod-wl-6.30.223.271-23.fc30.x86_64.rpm.
Could not open: akmod-wl-6.30.223.271-23.fc30.x86_64.rpm
[root@localhost /]# 

It does appear, therefore, that any installations of rpms needs an internet connection of some sort. I’ll need to submit a new topic as why my LAN won’t function.

1 Like

It couldn’t open the file. You need to specify the full path if it’s not in your working directory.

I fear that I’ve under informed you here for there are two issues: for I’m saying LAN when I should be saying wired connection. I’m using a Realtek RTL8111/8168/8411 which I understand Fedora 30 has the latest driver (r8189). I’ve searched pkgs.org for any updates on that. Per the Tp-link TL WN823N RTL8192EU, I’ve installed the latest kernel-devel ( [kernel-devel-5.1.5-300.fc30.x86_64.rpm] )(https://rpmfind.net/linux/fedora/linux/updates/testing/30/Everything/x86_64/Packages/k/kernel-devel-5.1.5-300.fc30.x86_64.rpm) but still have no wireless. Both return the error message: Activation of network connection failed Do you want me to create a separate topic for each of them or just one?

Just one should be fine i think

Hi QuLogic,

I appreciate your help.

I re-installed Fedora 30 and this is my immediate Terminal input:

[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora Modular 30 - x86_64                      0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'fedora-modular'
Error: Failed to synchronize cache for repo 'fedora-modular'
[root@localhost Downloads]# dnf config-manager --set-disable fedora-modular
[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora Modular 30 - x86_64 - Updates            0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'updates-modular'
Error: Failed to synchronize cache for repo 'updates-modular'
[root@localhost Downloads]# dnf config-manager --set-disable updates-modular
[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora 30 - x86_64 - Updates                    0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'updates'
Error: Failed to synchronize cache for repo 'updates'
[root@localhost Downloads]# dnf config-manager --set-disable updates
[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Fedora 30 - x86_64                              0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'fedora'
Error: Failed to synchronize cache for repo 'fedora'
[root@localhost Downloads]# dnf config-manager --set-disable fedora
[root@localhost Downloads]# dnf install broadcom-wl-6.30.223.271-10.fc30.noarch.rpm
Error: 
 Problem: conflicting requests
  - nothing provides wl-kmod >= :6.30.223.271 needed by broadcom-wl-6.30.223.271-10.fc30.noarch
(try to add '--skip-broken' to skip uninstallable packages)
[root@localhost Downloads]# 

The dependencies (links) kindly provided by ledeni are in the Downloads folder too

You need to specify all dependent .rpms that aren’t already installed. It won’t look in the current directory for dependencies (it’s not a repo).

1 Like