Iwlwifi driver randomly crashes, inoperable until reboot

Running a Dell XPS 9343 with an Intel 7260 wifi card. Since upgrading to F33, the WiFi driver seems to crash roughly every two weeks. I’ll usually be in the middle of something and notice that webtraffic has stopped, then notice that my WiFi still seems to be connected, but there are no available networks to connect to in Network Manager. Finally, a journalctl command will confirm the problem.

Below is the output of my last boot’s journal:
journalctl -b-1 -k

https://paste.centos.org/view/30e56fd4

Everything’s hunky dory until 03/01/21 21:05, then

Mar 01 21:05:21 malebolge kernel: iwlwifi 0000:02:00.0: Failed to wake NIC for hcmd
Mar 01 21:05:21 malebolge kernel: iwlwifi 0000:02:00.0: Error sending STATISTICS_CMD: enqueue_hcmd failed: -5
Mar 01 21:05:21 malebolge kernel: iwlwifi 0000:02:00.0: Failed to wake NIC for hcmd
Mar 01 21:05:21 malebolge kernel: iwlwifi 0000:02:00.0: Error sending STATISTICS_CMD: enqueue_hcmd failed: -5
Mar 01 21:05:26 malebolge kernel: ------------[ cut here ]------------
Mar 01 21:05:26 malebolge kernel: Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
Mar 01 21:05:26 malebolge kernel: WARNING: CPU: 3 PID: 0 at drivers/net/wireless/intel/iwlwifi/pcie/trans.c:2067 iwl_trans_pcie_grab_nic_access+0x1af/0x1e0 [iwlwifi]

And from there a kernel dump, followed by multiple instances of

Mar 01 21:05:27 malebolge kernel: iwlwifi 0000:02:00.0: Failed to wake NIC for hcmd
Mar 01 21:05:27 malebolge kernel: iwlwifi 0000:02:00.0: Error sending STATISTICS_CMD: enqueue_hcmd failed: -5

More dumps, eventually I give up and restart.

Any idea why this is happening? I didn’t try it on this boot, but on another failure I tried to bring the driver back with modprobe, but no luck.

Even a way to recover without a full-blown reboot would be welcome, as it’s quite a ding to my workflow.