Java can't find library

I upgraded from F32 to F33 yesterday. Today one of my programs is not working. The error is:

Failed to execute runnable (java.lang.UnsatisfiedLinkError: Can’t load library: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/lib/libawt_xawt.so)

Further down in the log it says it can’t find the file (neither could I)

The following 64-bit files are already installed:
java-1.8.0-openjdk
java-1.8.0-openjdk-devel
java-1.8.0-openjdk-headless
abrt-java-connector
java-11-openjdk-headless
javapackages-filesystem
javapackages-tools
tzdata-java

Is there something further I need to install?

1 Like
sudo dnf provides /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/lib/libawt_xawt.so
sudo dnf install java-11-openjdk-1:11.0.9.11-0.fc33.x86_64

https://dnf.readthedocs.io/en/latest/command_ref.html#provides-command-label

sigh…

Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418

1 Like

A similar issue:

Possible workaround:

sudo alternatives --set java /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.272.b10-0.fc33.x86_64/jre/bin/java
1 Like

Yeah!!! It works.

Thank you!

1 Like