KDE changed the themes of GNOME

I use GNOME, (Fedora 35)
Just to check out KDE, I installed it along side with GNOME.
I wanted to switch back to GNOME. (then I uninstalled KDE).
But now in GNOME all the icons, themes etc are similar to KDE (even though I did not change anything here).

Now, How am I supposed to get my default apperance that my GNOME had before installing KDE ?

How do I get rid of the changes made by KDE beck to my default look of GNOME ?
I really did not expect KDE to interfere with GNOME.
How do I solve this ?

See if you have a file ~/.gtkrc-2.0. If so, delete it.

Then logout and back in.

Whenever you install multiple DEs, there is the chance they can share config files and overlap slightly.

1 Like

Hi @dalto ,
I found that file and I deleted it.
Then I logged out and in but nothing changed.
Then I restarted but still nothing changed.
What should I do ? Cause it did not change even after deleting it.
Thanks in advance.

In the worst case scenario, you can just manually change the fonts and themes back to your preferences using gnome-tweaks

1 Like

Yea, not just fonts.
Even Icons changed and a lot more overlapped. Like for the wifi there are two symbols (for signals) instead of one icon and a lot more has changed (even the top bar) everything.
Is there anything I could do ?

1 Like

How did you install kde specifically?

You could try creating a new user account and seeing if the issues persist there.

You probably have two wireless applications installed. You need to uninstall one of them.

1 Like

To test different DE’s you best do this in a VM. You can just start the iso in a VM too.
Just a tip for your next DE adventurous.

sudo dnf groupinstall “KDE Plasma Workspaces”

Yes I did, but nothing changed :frowning:

Yea, that’s how I used to do it before, but I wanted try it out this way as this was a bit simpler process but it ended up interfering with GNOME.

Hi, if you still have KDE desktop installed, use KDE session and change the theme to Adwaita instead of Breeze.

Or if you already remove KDE, it will left breeze-icon-theme.noarch installed. Then you only need to remove sudo dnf remove breeze-icon-theme.noarch, log out and login again (or just reboot to make sure everything related to icon caches rebuild again).

The reason you get the KDE icon I believe it because breeze icon packages is currently in use by the system (system wide) instead of Adwaita.

Update:

There should be some mess up happen, I just tested. But it easy to fix and I believe will not harm the system since it only theme related.

For example after removing KDE desktop and breeze-icon-theme.noarch, on window app there still icon for minimize and maximize instead of close icon only. You can use gnome-tweaks then on the hamburger menu, click Reset to defaults.

There also different pop up window button if you let say want to upload an image with Firefox. It related to ~/.cache and ~/.config. You could run following workaround like:

# Restore .config. There should be a backup inside ~/.config/config/
mkdir ~/backup

# Move all ~/.config to newly created ~/backup folder
mv ~/.config ~/backup

# Move backup ~/backup/.config/config file to ~/
mv ~/backup/.config/config ~/

# Other things, you could go to ~/.cache and remove any name plasma and kde
rm -fr ~/.cache/kde*
rm -fr ~/.cache/plasma*

# Renaming ~/config to ~/.config
mv ~/config ~/.config

Recommendation:

It will be better if you still have KDE session installed, use the theme setting to change everything to exactly look like Gnome first (icon, button, ect), then remove it.

2 Likes