KDE discover always takes minimum 100MB before it starts

Fedora 34 KDE discover takes around 100+MB before it shows list of update. And takes around 5-10 mins

…updating package information (meta information).

The more repositories you have enabled, the more traffic it will cause. 5-10 minutes seems a lot, but if your internet connection isn’t the fastest, this may happen.

you can run sudo dnf update to see what is happening in the background during such meta information update.

There is literally nothing you can do about it (except to disable unused reporsitories)

Hey @jayp

Try to adjust the settings by following these steps:

Fastest mirror and Delta RPM

There are several things you can do to speed up your download times when using DNF to update your system. You can enable Fastest Mirror and Delta RPM. Edit /etc/dnf/dnf.conf using a text editor, such as gedit or nano. Here’s the example to open dnf.conf file with nano in terminal .

$ sudo nano /etc/dnf/dnf.conf

Append the following line onto your dnf.conf file.

fastestmirror=true deltarpm=true

Press ctrl+o to save the file then ctrl+x to quit from nano .

v/r
Andi

does KDE Discover even use dnf?

both are enabled by default, aren’t they?

2 Likes

use terminal

With dnf update it takes only few seconds.

Only repo enabled is Flatpaks

Want me to provide any logs or something ?

Settings under discover settings.

Strange after some tinkering I see these repos and made it default:

But still it takes lot of time at “Fetching update…” Stage.

@jayp Have u changed on terminal the settings as I have wrote?
Actually this should speed up as well in Discover.

1 Like

Okay. Let me try those settings. I am travelling for three days but will get back after Tuesday.

nice! :slight_smile:

Have a nice weekend.

v/r
Andi

1 Like

Depending on your internet speed you may want to also look at:

max_parallel_downloads it defaults to 3.

reference: DNF Configuration Reference — dnf latest documentation

Looking at the screenshot do you need to install the flatpak or packagekit backends for this to work correctly? (not a Discover user it just seems odd to me)

2 Likes

I don’t remember doing anything different. Only thing installed via flatpak is VLC player.

1 Like

Solved problem by deleting flatpak…

New users should do
sudo dnf remove flatpak

1 Like