KDE fails to boot on certain Nvidia graphics cards in UEFI mode

Problem

On systems with certain Nvidia graphics cards, Fedora 36 KDE fails to boot in UEFI mode. This includes both the Live installer image and the installed system.

It only happens in combination with Wayland display protocol, but the KDE login screen it configured to use Wayland by default, so this happens every time, unless the settings are changed in the installed system.

Cause

Not yet known. In general, Nvidia’s attitude towards Linux.

Related Issues

Bugzilla report: 2077359 – KDE on X11 with native graphics hangs with Nvidia GPU and UEFI

Workarounds

You have the following options:
A) Switch your system to BIOS mode instead of UEFI and install Fedora that way.
B) Boot the install in Safe graphics mode (available under the Troubleshooting boot menu). After system install, either install the closed-source nvidia driver (if you intended to do so), or set KDE to always use X11 instead of Wayland, including the login screen. Then edit the grub config files to remove the nomodeset keyword (triggering safe graphics mode) and rebuild the installed grub bootloader config.
C) Install Fedora Workstation (GNOME) instead of KDE.
D) Switch your graphics card to a more Linux-friendly vendor (AMD, Intel). You might already have an integrated graphics card in your CPU which you can use instead of the Nvidia external one.

1 Like