KDE - initial keyboard layout after login

I’m running Fedora 33 with test updates, KDE.

There are two keyboard layouts configured: EN and RU.

For as long as I can remember, the initial layout after logging in was always EN. I’m not talking about the login screen, but about the layout once I’m logged into KDE proper.

Now for the last few days or so, the initial layout is RU. This is mildly annoying, as the first thing I do every day is start a few terminal windows and run some commands.

What could be the reason for this change of behavior and how can I revert?

  • KDE Plasma 5.20.5
  • KDE Frameworks 5.79.0
  • Qt 5.15.2

I set my layouts in a /etc/X11/xorg.conf.d file, it’s been that way for years:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbOptions" "grp:rctrl_rshift_toggle"
EndSection

In KDE Keyboard settings, same two languages are listed, with EN being above RU.

Finally, in Regional settings, I’ve got American English and only that.

Why does KDE now think that I want the RU layout and how can I make it stop please?

One more thing.

The most recent KDE related update was KDE Frameworks 5.78 to 5.79 a few days ago.

However, I’ve got a SuSE Tumbleweed installed, which uses KDE Frameworks 5.79 (and a newer KDE version, 5.21) - and the initial post-login language there is EN. Layouts there are configured the same exact way (as in Fedora).

So this issue looks to be Fedora specific?

Um somehow it fixed itself after I disabled the list of layouts in KDE layouts settings and rebooted. The setting changed back on, and the initial layout is EN again.

It looks like that the Layout on first position is the default one. If you have a list of layouts just move the EN on the top. At least so it works in Mate-Desktop.