KDE login doesn't work after logout

I just installed F30 to a new hard drive. I prefer to use KDE/Plasma but have noticed what seems to be a glitch.

If I logout of a session, logging back in seems to fail. All I see is a black screen with a cursor when login “finishes”. Rebooting is required to get the desktop back. I don’t seem to have the same problem with Gnome.

I tried the commands from this page: https://forum.kde.org/viewtopic.php?f=309&t=151520 (changing “apt” to “dnf”). The first 2 returned “nothing to do”. The third “dnf install -f” is invalid syntax.

any other suggestions?

1 Like

They’re simly suggesting that you update your system to ensure you’re running the latest versions of the software.

Yes! We need more information before we can diagnose the issue. Can you have a look at the system logs please and see what it says when you’re login fails? More information on how to view logs is on this page:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

Since there is an incomplete part of kde during initial installation, you need to install xorg related programs and add support libraries, also kde and library etc. also It works well.

There may be some incomplete parts, but it seems to be able to have a more stable system by solving the problem and supplementing the part. also kde show little bug…like a language input problem.

F30 KDE System User.

It looks like it might have something to do with kglobalaccel

kglobalaccel5 seems to be triggering core dumps and there’s something about “process 21870 (kglobalaccel5) crashed in ??()”
Then “Unrecoverable failure in required component org.gnome.Shell.desktop”

kaccess[5117]: Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.NoReply", "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.")

ksmserver[5121]: Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.NoReply", "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.")

kdeinit5[5105]: Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.NoReply", "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.")

otherwise:
There’s a message about colord: “/home/user/.local/share/icc/.” is not an ICC profile
There are errors about “couldn’t start kglobalaccel from org.kde.kglobalaccel.service: QDBusError”
It doesn’t seem to like the Nouveau video drivers