Kernel 5.11.X boots to black screen

HP 14-dk0002d boots to black screen after updating to kernel 5.11.7 and 5.11.8 no grub no slash screen no nothing just black
Boots fine on 5.10 kernel
Laptop has AMD A9-9425 processor and integrated AMD Radeon R5 Graphics
Any idea how to fix
This is not my laptop so would like to find a fix asap
Temporary fix removed 5.11 kernels and ask them not to update until I found a solution

1 Like

I have same problem going from 5.10.23-200.fc33 to either 5.11.7-200.fc33 or 5.11.8-200.fc33 on my Dell Precision 7510. Seems to be stuck on some systems units and a lot of module loading errors

Can you tell me how did you retained the original state of kernel…
I mean how did you removed 5.11 …if you remove that what version would be there?
and while installing kernel 5.11 would that conflict the previous ones of 5.10?

Not sure what you mean. DNF is set to keep 3 versions of kernel. When first 5.11.7 got installed and I reboot it fail to start fully. I just rebooted back into 5.10.23. Then 5.11.8 was released, tried to boot into that, failed again and went back to 5.10

According to the bugzilla report, kernel 5.11.9 should fix the problem: 1936791 – Kernel 5.11 - Unable to boot beyond GRUB menu on FC33. It’s working its way down the pipeline now and it should show up very soon.

So does that mean when we delete the latest kernel version
then the system switches to the last kernel version it was into??.. And if the laptop failed to start up how did you rebooted back

With a kernel update, dnf does not remove the currently booted kernel. So if you are booted into a working version of 5.10 then the update installs another 5.11 version you are still safe.

ie. booted to 5.10.23, already installed 5.11.7 & 5.11.8 makes the 3 kernels dnf keeps. Update installs 5.11.9 and removes 5.11.7 since 5.10.23 is in use. You still have 5.10.23, 5.11.8 and the new 5.11.9 to boot from.

1 Like

Yeah, and on top of that, as this has happened to me in past, I bump up the dnf config installonly_limit so I make sure the working kernel doesn’t get removed until I get a new working one and I drop the limit back down

How did you do that?
I mean what commands?

Edit the file /etc/dnf/dnf.conf and change the value there.

1 Like

Good to hear there is a kernel fix on the way.
I assumed that was the problem but just in case thought I would ask
You really do not have to remove the kernels
I did that because the owner is not computer savvy
This way they do not have to jump through hoops to start their laptop
Just push the power button and boot into the laptop

5.11.9 kernel is out. Try the update and see if the problem is fixed. If not then please file a bug report.

It’s in the and conf file in /etc/dnf

I am so happy to see this thread. I have had this problem but not been able to solve. I just updated to 5.11.9 but the problem persists.

Success kernel 5.11.10 fixed it
I did not try 5.11.9, read it was buggy, so not sure if that kernel fixed it

Seems you were using AMD GPU, i am also using AMD GPU, and failed to install fedora on my PC,
I am using R560 4GB Graphic cards.

Is it the xorg driver problem?

I had similar problem earlier today after trying to install a NVIDIA driver. Worst case scenario had happen unfortunately. After black screen. I rebooted and tried to change the hardware bios setup becourse I guess I removed the Noveau Kernel which where locked and blocking the graphical driver to work.

If everything is tried out. DON’T PANIC. You can reinstall by your boot DVD/USB and install and update to the new Fedora OS.

Sad thing that I had to start all over by installing software. Good thing was that I thought I was stocked and lost in getting online by using the Fedora OS. Now everything works.

Try to reboot: CTRL + ALT + Delete. > press any F* key ( I am not sure which from F1 - F12 ) Giving your exit to the Recovery session. Where you can choose earlier versions from system back up or an safe version.

i had the same problem fixed it by adding dis_ucode_ldr to the boot paramaters. this is how:
when grub gives you the option to select fedora, press e, then go to the line that starts with Linux, at the very end of that line type dis_ucode_ldr then press f10 or ctrl+x . if that doesnt work then try again and instead type nomodeset. cheers

thats not the problem, most likely its a problem with firmware in the new kernel. at least thats what it was for me. dis_ucode_ldr as boot parameters fixed it