Kernel-5.2.5-200.fc30.x86_64 black screen after login

This is what I am looking for:
Where is the archive of the old Ask Fedora?
Need to downgrade the kernel persistently and prevent it from updating. Too much “alfa” is not a good thing, Fedora!
And of course remove the updates repostory, The old “Ask Fedora” had much more valuable info.



should do

=> man dnf.conf

Have a look to these posts:


However you have an issue that should be investigated.
Let me understand: if you boot kernel-5.2, the graphical login screen appears, but once logged in the desktop stays black. If you boot kernel-5.2, and you go to a virtual console (ctrl+alt+F1), then you log in and you issue startx, Xfce start normally?

P.S. Fedora is not alpha. It is a characteristic of Fedora to provide updates at a relatively fast pace, and it is a reason why many people use it. But it is a myth that Fedora is a bleeding edge distribution. It is difficult that you will find alpha or unstable software. Same thing for the kernel. But software is software, and has bugs; something that works for me could go wrong in your environment. And since we use free software and such software is supported by a community, we have the possibility to file bugs, we can help each other, we can contribute to solve problems.

1 Like

Not for me. If I boot kernel-5.2, press Ctrl Alt F3 (F1 is the graphical interface on my system) on the login screen and run startx, then I can see the Xfce desktop for a few seconds and then get a black screen again. But that may be an additional error on my system if that way is working for peterjmb. Unfortunately I also have no report-able errors in the Problem Reporting app.

As we both have an error in the logs about the amdgpu driver - could it probably be an incompatibility between the amdgpu driver and kernel-5.2?

Edit: I tried to remove xorg-x11-drv-amdgpu from my system, but that didn’t make a difference with kernel-5.2.6. However, I found out that the way via another terminal and startx would work for me too if I use only the internal display and no additional external display, but I see a lot of screen artifacts in areas with recently refreshed content.

@alciregi and @zookhra it isn’t Xfce or Amd, it seems to be Samsung:
Samsung SSD EVO is the disk I use Fedora on.
But I still can boot it from kernel 5.1

I’m not so sure that that is the real problem source. I also have a Samsung SSD (MZVLB512HBJQ) in my system, but I don’t see any ATA or DRDY errors in /var/log/messages.

However, I decided to switch back to Arch. Interestingly I hadn’t the problem after the set up (Xfce 4.13 and kernel 5.2.x), but the same problem started when I updated my system to Xfce 4.14 when it was released. The solution was to disable the option “Display fullscreen overlay windows directly” in the Window Manager Tweaks/Compositor before the update. Maybe this will help you too. As a first check you can try to disable compositing in Xfce. That can be done via the terminal too: xfconf-query -c xfwm4 -p /general/use_compositing -s false.

1 Like

It is the kernel, and only the kernel. Tried it out in other Linux with Mate GUI on another computer, the same: Old kernel version works, starting from kernel version 5.2 exactly the same problem: frozen black screen after login, no cursor or whatever, have to forcefully power-off and start from older kernel that works. Screenshots from Fedora after starting from kernel 5.1 about system failure that cannot be reported and the last screenshot from terminal in /var/spool/abrt, a whole bunch of the same. This isn’t funny anymore. The developers have to fix their kernel, which probably will only work on some computers but on none of mine!

Bug 1742960
Similar to

Somebody found a temporary solution! See comment 26 in this bug report:

Create a shell script at /etc/profile.d/ and add export AMD_DEBUG=nodcc to it. Next, run chmod +x /etc/profile.d/ to add execution permissions. The next time you boot with a 5.2.X kernel, everything should work normally.

I tested this on a Lenovo T495 with AMD Ryzen Pro 3700U running Fedora 30 (kernel 5.2.9) with XFCE.

Edit: Fixed missing text in the script.

Notice: I unmarked the previously marked solution, since it wasn’t the solution.

It’s a (possible?) workaround, not a solution, but it can be still quite useful to people suffering from this, so thanks @blazin64 for sharing this!

It would be great if some of the people bitten by this bug could try this and report if it help them as well.

And by the way, @blazin64, welcome to the community! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so. ))

1 Like

I should’ve been clearer—another post on “locking kernel versions” was marked as a solution, so I unmarked it. @blazin64’s post is much nearer to the solution.

1 Like

Note, that executable bit is redundant for the files in /etc/profile.d/.


There is no solution until the day the developers rewrite the kernel.
Just tested kernel-5.2.11-200.fc30.x86_64
The problem remains.

Thank you for the “turn off compositing” hint, and the command line! I have the same issue on a ThinkPad T495s (Ryzen 7 Pro 3700U).

In fact I have had this issue for almost half a yr on my Ryzen 5 2400G desktop also! I have been keeping around a 4.x series kernel just to keep it bootable.

I wonder what’s the right channel to report to the devs, I have filed bug reports on the RedHat bugzilla regularly, but that has gathered dust (as in, not a single dev/maintainer commenting on it) every time it has been a kernel issue (other reports have received reasonable attention).

Reporting Bugs (
But distro maintainers probably need to be notified too.

1 Like

@vits95 Well, on the RedHat bugzilla my bugs have been assigned to “Kernel Maintainer List”. I have even tried highlighting my bug reports individually on bodhi kernel updates, #fedora-devel IRC, and even phoronix. So short of writing to lkml, or posting on the radeon IRC, I really don’t know how else to notify devs. I haven’t tried the last two because then I would need to compile my own vanilla kernel, which I don’t think I have the technical chops for.

If i remember well...

Zero, make sure your’re not root; make sure that your have some free GB on your storage (default ones is hard on it).

First, your need to download sources (see for vanilla Kernel sources).
Second, your need to unpack it somewhere in your “home” (we call it Хомяк (Hamster)). And open terminal inside of the dir created by unpacking.
Third, your need to issue make clean. Then mkdir ../bld.
Fourth, your need to make olddefconfig O=../bld. if your’ve spare CPU cores, use -j flag.
Fifth, wait. Be careful with make modules_install; make install, because it may not respect the usual file order from this distriburion. I’ve once broked my Trisquel

OK, there is simply need to be some normal docs around! But almost any fool can do it, i’m is an primer.

PS: Inside of the kernel sources, there was an “README”, or “INSTALL” file…

Okay, I will give it a try then.