Kernel upgrade/remove doesn't update grub automatically

Hi
I have installed Fedora 32 KDE spin using Calamares installer. I used Calamares because unlike Anaconda it lets me to install grub on root partition. However, there is a problem with this installation method, upgrading and removing kernels doesn’t automatically update grub and I have to do this manually. Is there a way to automate this process?
Thank you in advance and sorry for my english

1 Like

Post your configuration:

cat /etc/default/grub
1 Like

GRUB_DEFAULT=‘saved’
GRUB_DISABLE_RECOVERY=‘true’
GRUB_DISABLE_SUBMENU=‘true’
GRUB_TERMINAL_OUTPUT=‘console’
GRUB_TIMEOUT=‘5’
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash resume=UUID=898ebf06-8950-4e62-ab97-
549b4600be51”
GRUB_DISTRIBUTOR=‘Fedora’

1 Like
sudo grub2-switch-to-blscfg

https://fedoraproject.org/wiki/Changes/BootLoaderSpecByDefault

Note that in some cases you need to reset GRUB environment to make it work properly:

sudo grub2-editenv create
2 Likes

Thank you, I will wait for next kernel upgrade and report the result

1 Like

This didn’t solve the issue. The latest fedora kernel is 5.8.16 and I’m stuck on 5.8.15 due to grub which isn’t automatically updated.

Verify that BootLoaderSpec is enabled:

grep -e GRUB_ENABLE_BLSCFG /etc/default/grub

Sorry, It seems that Kde discover hadn’t install latest kernel on my machine. I must investigate this issue further. I upgraded my system using dnf and this time grub updated automatically added kernel 5.8.16 to my boot menu. I just wonder why do I have 3 kernel entries in boot menu while I have installonly_limit= 2 in dnf.conf. In other word, grub doesn’t remove kernel 5.6.6 form boot menu while it has been removed by dnf.

1 Like