Keybindings for workplaces higher than 4 cant be activated with gsettings

On several other distributions I used the tweak tool to set the number of static workspaces to 9 or 10. And then issued the gsettings commands like this -->

" gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-5 ‘[“5”]’ "
" gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-6 ‘[“6”]’ " etc.

That only works for workspace 1 to 4 but not for workspace 5 and higher. Any hints, please?

Hi, I had same problem.
By an experimental way I found next well working settings:

gsettings set org.gnome.mutter dynamic-workspaces "false"
gsettings set org.gnome.desktop.wm.preferences num-workspaces "10"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-1 "['<Super>1']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-2 "['<Super>2']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-3 "['<Super>3']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-4 "['<Super>4']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-5 "['<Super>5']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-10 "['<Super>0']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-up "['<Super>K']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "['<Super>J']"

I have keybindings for 1-5 and 10 workspaces, other (6,7,8,9) I’m open with workspace-up (Super+K) or down (Super+J) keys.
It’s work fine for me, but I’m use Fedora Rawhide Silverblue, don’t shure how it’s work on Fedora 30.
Sorry for my bad English. Best regards.

1 Like

This might be a hint why my settings work on other distros. Maybe the settings format changed with the Gnome version in Fedora 30.

I found a solution. The keybindings from “switch-to-application” interfered with “switch-to-workspace”. After giving the ones from “switch-to-application” another binding the others work as needed.
:slight_smile:

Edit: wrong wording

4 Likes

I tried it and it’s work perfect. Great solution.
Now I have hotkeys for all my workspaces :partying_face:
Many thanks.

1 Like

@neopat, it could be useful for others searching for similar issues if you’ll mark your post as a solution (thus marking this entire thread as resolved).

1 Like