Keyboard map issues with accents

Hello,

I am facing a hard time trying to configure an US Keyboard to fully support accents (Portuguese Brazillian). After extensive search and attempts I still could not fix it. I’d like help to figure out what is wrong in the process.

My system language is English (US).
The embedded keyboard of my notebook is Brazilian Portuguese ABNT. It works fine, with accents, if I select this layout.

But I am trying to use an external apple keyboard (EN US). It also works if I select EN-US, but without any accents. Ie. “~+a” should give me “~a” instead of “ã”.

  • Portuguese (Brazil, Nativo for US keyboard) which work for Linux Mint gives an completely wrong keymaping (https://www.dropbox.com/s/tp1vlzmt8abfygd/IMG_9422.MOV?dl=0)

  • I found references online that “system-config-keyboard” tool should me allow to configure. But it does not work by default in F31 since apparently it expects python2 and the call script uses ‘python’ (default to 3 in F31). Even after fixing that and installing extra packages, it still does not work

    File "/usr/share/system-config-keyboard/keyboard_tui.py", line 32, in <module>
      import system_config_keyboard.keyboard as keyboard
      ModuleNotFoundError: No module named 'system_config_keyboard'
    

Anyone has any idea of how can I use EN-US as system language and US International keyboard, but with accents? (just as it already works if I use a PT-BR keyboard)

Thank you very much

[mario@aspire ~]$ lsb_release 
LSB Version:	:core-4.1-amd64:core-4.1-noarch
[mario@aspire ~]$ uname -a
Linux aspire 5.3.15-300.fc31.x86_64 #1 SMP Thu Dec 5 15:04:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[mario@aspire ~]$ localectl
   System Locale: LANG=en_US.UTF-8
                  LC_NUMERIC=pt_BR.UTF-8
                  LC_TIME=pt_BR.UTF-8
                  LC_MONETARY=pt_BR.UTF-8
                  LC_PAPER=pt_BR.UTF-8
                  LC_MEASUREMENT=pt_BR.UTF-8
       VC Keymap: br-abnt2
      X11 Layout: br,us,br
     X11 Variant: ,,nativo-us
[mario@aspire ~]$
1 Like

Based on multiple search results, what I want is something like:

setxkbmap -model pc105 -layout us -variant intl

but it is not working. Maybe it has some relation with the wayland migration in F31? (and the tool being for older X)

@mbn12

Hi. For the language section, the language and keyboard settings can be applied after installing various libraries, and it seems that you can set the language you want in your KDE.

Other than the KDE Konsole bug, it works great for different configurations and behaviors, and I use it very well.

I set ibus to KDE, and install ghc-language, glibc, and ibus* in the language configuration part, I think that language support part will be used without any problem.

I am currently using Fedora31 Server KDE. Have a nice day!

Hi @simmon

I am using GNOME 3 and could not do that by default.

After installing gnome-tweaks and enabling “show extended input sources” I was able to fix the issue: when adding a new input source, after selecting the language (English (US)) another menu appears selecting the variant (which I’ve chosen us-intl for my case).

That should be the default behavior, IMHO. We should not need to install extra tools, tweaks, etc… just to select the variant of the keyboard/language.

Alternatively, I also found that using dconf-editor it is possible to directly edit the language/input sources in /org/gnome/desktop/input-sources/sources and modify a given entry:

[('xkb', 'br'), ('xkb', 'us')] --> [('xkb', 'br'), ('xkb', 'us+intl')]

being the +xxx the keyboard variant.

Cheers

PS: apparently in the X/wayland transition of F30 - F31 some things changed and that’s why setxkbmap does not work anymore, for instance.

2 Likes

There were definitely some problems with the X/wayland transition. I found a different one not long ago involving drag-and-drop. If you happen to encounter that, here’s the info:

2 Likes

ok. have a nice day…seoul rainy and cold… entering winter!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.