Keyboard not working on first boot after shut down the system

Hi ! i recently bought a Asus zenbook 14 laptop from store and i was planing to use fedora on it, but a strange issue appaired since i installed the system, on first boot after shut down my keyboard is not responding , just after i restart the system from sign in screen it will work ,any ideea how to solve this issue?

1 Like

Is this the keyboard built into the laptop? If so, are you able to attach a USB keyboard and get input?

hi, yes the keyboard is built-in, and i tried to use a usb keyboard and it works , but i still want to use my laptop one, cause sometimes i travell and i dont want to carry an extra keyboard with me

1 Like

Great! With your USB keyboard, run libinput debug-events --show-keycodes, then start typing on your laptop keyboard. Do you see the typing events logged in the terminal? (Don’t leave this running so you don’t accidentally log passwords, etc).

Failed to open /dev/input/event3 (Permission denied)
Expected device added events on startup but got none. Maybe you don’t have the right permissions?
I get this messege and my laptop keyboard sill doesent work.

Trying running the same command with sudo in front of it :slightly_smiling_face:

i still don’t get any input from keyboard, just from my mousepad and usb keyboard

If you’re not seeing any events logged in the terminal after running that and typing on the laptop keyboard, then that means the keyboard is no longer recognized. Does it show up with sudo libinput list-devices? I suspect it would show up as “USB Keyboard”, so you should see two entries for that with your other keyboard plugged in, assuming it’s the same as my ThinkPad, which has entries like this with an external and internal keyboard both working:

Device:           USB Keyboard
Kernel:           /dev/input/event11
Group:            11
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           USB Keyboard
Kernel:           /dev/input/event12
Group:            11
Seat:             seat0, default
Capabilities:     keyboard pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Can you also verify what version of Fedora and what kernel (uname -r)?

yes it shows quite the same things on command window after i’ve put the comand ,but i thinks is just a prob with my keyboard on linux, i’ve seen similar issues on forums with the same model, they fixed it by editing the kernel and stuff, i don’t know how to do that.Thanks for your help! :smiley:

If you want to try that out, here’s how you would edit the boot options in Fedora:

https://docs.fedoraproject.org/en-US/fedora/latest/system-administrators-guide/kernel-module-driver-configuration/Working_with_the_GRUB_2_Boot_Loader/#sec-Editing_a_Menu_Entry

1 Like

Thank you,i’ll have a look!

1 Like