Lamobo R1 Network

I have Fedora 30 installed on a BananaPi R1 (Lamobo R1). It works. Only I can not get the network configuration.
The Lamobo has one WAN and four LAN interfaces. The WAN interface should get its IP via DHCP. The devices on the four LAN interfaces should also get IPs via DHCP. The DHCP server is running on a different machine and works.
In the basic configuration, without changes by me, the Lamobo gets on the WAN interface no IP via DHCP. Why, if he is set to DHCP by default?

[root@localhost ~]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
 inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
 link/ether 02:58:03:42:51:e1 brd ff:ff:ff:ff:ff:ff
3: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state LOWERLAYERDOWN group default qlen 1000
 link/ether 02:58:03:42:51:e1 brd ff:ff:ff:ff:ff:ff
4: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state LOWERLAYERDOWN group default qlen 1000
 link/ether 02:58:03:42:51:e1 brd ff:ff:ff:ff:ff:ff
5: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state LOWERLAYERDOWN group default qlen 1000
 link/ether 02:58:03:42:51:e1 brd ff:ff:ff:ff:ff:ff
6: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
 link/ether 02:58:03:42:51:e1 brd ff:ff:ff:ff:ff:ff
 inet6 fe80::5a19:1aaa:9244:aaaf/64 scope link noprefixroute
    valid_lft forever preferred_lft forever
7: lan1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state LOWERLAYERDOWN group default qlen 1000
 link/ether 02:58:03:42:51:e1 brd ff:ff:ff:ff:ff:ff
8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
 link/ether 28:f3:66:41:95:51 brd ff:ff:ff:ff:ff:ff
 inet 192.168.137.178/24 brd 192.168.137.255 scope global dynamic noprefixroute wlan0
    valid_lft 604687sec preferred_lft 604687sec
 inet6 fe80::363a:1112:6265:58d6/64 scope link noprefixroute
    valid_lft forever preferred_lft forever

Ich habe Fedora 30 auf einem BananaPi R1 (Lamobo R1) installiert. Es funktioniert. Nur die Netzwerkkonfiguration bekomme ich nicht hin.
Der Lamobo hat ein WAN- und vier LAN-Interfaces. Das WAN-Interface soll seine IP per DHCP bekommen. Die Geräte an den vier LAN-Interfaces soll ebenfalls IPs per DHCP bekommen. Der DHCP-Server läuft auf einer anderen Maschine und funktioniert.
In der Grundkonfiguration, ohne Änderungen durch mich, bekommt der Lamobo am WAN-Interface keine IP per DHCP. Warum, wenn er doch standardmäßig auf DHCP eingestellt ist?

Hello.
That’s just a guess.
Can you provide the output of
firewall-cmd --get-active-zones

[root@localhost ~]# firewall-cmd --get-active-zones
public
  interfaces: wlan0 eth0

Hi @ralfhs—welcome to the community! If you have a minute or two to spare, please look at the posts in #start-here. They quickly summarise how to use Discourse effectively—including formatting text and so on.

Thank you.
And what about the output of the following command?
sudo firewall-cmd --list-all

I am logged in as ROOT.

However, it should be avoided to work as root when you can use sudo.
BTW it doesn’t matter: what is the output of such command?
My doubt is that the firewall is preventing DHCP to work.

The Output is:

public (active)
target: default
icmp-block-inversion: no
interfaces: bridge0 eth0 wan
sources:
services: dhcpv6-client mdns ssh
ports:
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

I added a bridge. To the bridge I added the interfaces WAN, LAN1 - 4 and ETH0 and disabled STP. Now ETH0 gets an IP via DHCP, but constantly “Connect” messages are generated.