Language layout not changing

Hello Community,

I am using Fedora 37beta and I have got problems with the layouts.
Using Gnome tweaks I choose “Left Alt+ Left Shift” in “Switching to another layout”
Technically it works, because when I am switching between layouts it works, but indicator below is not changing.
Tried reboot - didn’t help
image

Any suggestions?

The indicaer indeed will not update this way, and I do not know of a solution.

With Gnome Tweak tools, you are setting XKB options. This works at a “deeper” level in the system than Gnome Desktop. Gnome Desktop does not “see” that keypress and thus does not update the indicator while XKB is doing its job at a deeper system level.

Either you will have to live with that (perhaps it is possible to have the language indicator removed), or you can use a keyboard combination, customizable in Settings - Keyboard, Keyboard Shortcuts, section “Typing”. The default shortcuts is + to cycle to the next language, with the key to cycle back. These shortcuts are restricted to combinations of a modifier key and a regular key, though.

Strange… on Ubuntu 22.04 it is working well. (gnome tweaks way)
When I switching using “Windows+Space” the indicator is switching. Is there a way to change this shortcut?

Settings - Keyboard, Keyboard Shortcuts, section “Typing”.