Latest kernel killed my WiFI

Rebooted with 5.2.8. all is good. Funny though, it updated to like 5.2.11, so I rebooted with 5.2.9 and still no wifi. Had to fall back two kernels to 5.2.8.

Anyone else, or am I just lucky?

$ sudo lspci -v | grep “Network controller” -A 12
06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
Subsystem: AzureWave Device 2161
Flags: bus master, fast devsel, latency 0, IRQ 55, NUMA node 0
I/O ports at c000 [size=256]
Memory at fe600000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 00-e0-4c-ff-fe-87-2b-01
Capabilities: [150] Latency Tolerance Reporting
Capabilities: [158] L1 PM Substates
Kernel driver in use: rtl8821ae

Hmm this is a bit bizarre, that driver wasn’t touched at all in 5.2.9. My thought was maybe it’s a bad mix of linux-firmware and the kernel, but those firmware files haven’t been touched in quite a while.

On a boot where the WiFi fails, what do dmesg and journalctl -b -u NetworkManager say?

2 Likes

Well, I switched back to the 5.2.11 to see and it magically worked (go figure). Well, I don’t what to say. I swear I booted that kernel 5 times or more and nothing. Now, all good. IDK lol

Some updates may require additional actions to apply properly:

1 Like

Not that it matters now; but the link you gave is for 5.2.9 which as fine when I was using it. The problem I had was with 5.2.11 (only after that update did 5.2.9 stop working, so I fell back to 5.2.8). Now, for what ever reason, 5.2.11 seems to have un-pooped itself.

Appreciate the input though guys and or gals.

1 Like