LibreOffice auto-correct tool disabled

Hi. I verified LibreOffice’ s own help system, so out of frustration I dare to ask here. I use LibreOffice with English interface to write in Spanish, with no issues so far. Since last week, the auto-correct tool stopped working in Fedora 33. This happens the same with LO 7 (as packaged by Fedora) and LO 7.1, manually installed. I even re-created my user configuration folder, but the problem persists. The lack of reports from LO’s help system, and the occurrence with both versions 7 and 7.1, suggest to me this might be Fedora-related. Has someone else seeing this happening?

1 Like

Hi, do you have libreoffice-langpack-es and libreoffice-langpack-en installed? Those should pull in necessary auto-correction packages.

Shift+F7 toggles auto-correction (it’s status is visible in Tools menu).
Look through Tools → Settings → Language settings, maybe some settings needs to be enabled.

Lastly, personally I use flatpacked LibreOffice, you can give it a try:

1 Like

Hi, ozeszty, and thanks for answering.
Yes, I have both langpacks installed. They were working OK until a week ago. I did not recall changing any LibreOffice setting. The only thing I did by the same time was upgrading my Fedora 33 Gnome to version 40 alpha, but I can’t see how that could have something to do with my current issue with LB.
On the other side, I will definitively try the flatpacked road. Thanks for the tip.
Update: I tried the flatpack version (the one from the flatpack channel; there’s another from the fedora channel but it’s just version 6.4; odd) and looks and behaves fine, auto-correct included. However, it does not include langpack-es, and I failed finding a flatpacked langpack-es version.
Second update: Nevermind. I took the extensions road and installed a Spanish grammar extension. Now, I got both my auto-correct tool and Spanish grammar back. As a bonus, I am running the latest and greatest LibreOffice version. I couldn’t be happier.

Selective upgrade to alpha software from different release (F34/Rawhide) seems like a quite possible cause :wink:
With dnf history you can check whether some dependency was removed in the process.
With dnf distrosync you can go back to current F33 packages.

Great that you managed to get flatpak version working, if my answer helped you, mark it as solution.

PS There’ll be F34 internationalization test day, join it to make sure F34 and Gnome 40 works well with your locale:
https://fedoraproject.org/wiki/Test_Day:2021-03-09_I18N_Test_Day

1 Like

Marked. Thanks again. So far, everything is working fine.