Login Screen on wrong monitor

Hello, I have 3 monitors.
When I start up my PC the login screen is on the left most one. Once I am logged in though the center one is the only one with the gnome bar (which is what I want). How can I move the login screen to the center monitor? I am using nvidia btw.

Do you use Gnome or some other DE?

If you do use Gnome, then please verify, does your session use Wayland or X11 – like described in the first answer to this question:

1 Like

I am using x11. Also using Gnome and F31

In such a case Gnome’s monitors configuration is stored in the file ~/.config/monitors.xml. The simplest solution is to configure your monitors in your session as you want them, and then copy this config to the gdm user – this is a system user running Gnome’s login screen.

One more note: this is assuming you’re running gdm as a login manager (there are others, they will
be different).

To copy config file you’ll need this two commands:

sudo cp -v ~/.config/monitors.xml /var/lib/gdm/.config/ 
sudo chown gdm:gdm /var/lib/gdm/.config/monitors.xml

First one does the copying, second changes ownership of the file to the gdm user.

As far as I remember from my testing, after copying the file you can just switch to gdm screen with [Ctrl]+[Alt]+[F1] to see the difference immediately. You can return to your session either by entering your password to unlock the session or by pressing [Ctrl]+[Alt]+[F2] (or sometimes F3, F4… up to F6).

And one more note. There’s a change your monitors.xml contain some settings that gdm doesn’t like. We’ve had such a case here on Ask Fedora. In such a case gdm will just ignore the file you give it.

One of easier solutions is to delete your own monitors.xml, generate new one by going to Gnome’s Control Panel and configuring your monitor’s setup anew – and saving it – and then repeat the commands I’ve given above to copy it to gdm’s config anew. This all should work without logout or rebooting (at least it did for me on Wayland session).

2 Likes
  1. I did these commands like you suggested.
  2. I then restarted. Login screen was on the correct monitor. The GNOME primary display was on the wrong one. So I went and changed the primary display in my GNOME settings.
  3. I restarted again. This time both the login screen and the GNOME primary monitor were on the same correct display.

Thank you.

2 Likes

You’re welcome!

It’s easy when you know what to do. Maybe someday Gnome’s control center will have a provision to configure monitors setup for gdm – but until then we can do it manually.