Lost 5Ghz wifi after moving from F28 to F30

Both wifi bands (2.4Ghz and 5Ghz) worked fine in F28.
Moved from F28 to F30 using ‘dnf system-upgrade’ route. All went well, no errors, been using F30 for about 2 months.
Now, after some updates, F30 wifi will only connect to 2.4Ghz and does not find any 5Ghz Access points.

Laptop is a Dell xps-9370 with

Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)

Checking for the available frequencies using ‘iwlist’ gives this;

iwlist wlp2s0 frequency
wlp2s0    32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:2.412 GHz (Channel 1)

That matches the AP I am using


wlp2s0    IEEE 802.11  ESSID:"wifi_2"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 46:D9:E7:03:CE:CB   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=69/70  Signal level=-41 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:80   Missed beacon:0

So 5Ghz channels are shown.

Also, checking with

dmesg | grep 'ath\|firmware'
 4.700211] Bluetooth: hci0: QCA: patch rome 0x302 build 0x3e8, firmware rome 0x302 build 0x111
[    4.702367] ath10k_pci 0000:02:00.0: enabling device (0000 -> 0002)
[    4.709783] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    4.918572] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:143a
[    4.918574] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[    4.918986] ath10k_pci 0000:02:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[    4.982994] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[    5.050905] ath10k_pci 0000:02:00.0: unsupported HTC service id: 1536
[    5.148073] ath10k_pci 0000:02:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    5.213426] ath: EEPROM regdomain: 0x6c
[    5.213426] ath: EEPROM indicates we should expect a direct regpair map
[    5.213428] ath: Country alpha2 being used: 00
[    5.213428] ath: Regpair used: 0x6c
[    5.230188] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0
[    6.388560] ath10k_pci 0000:02:00.0: unsupported HTC service id: 1536
[    6.680537] ath10k_pci 0000:02:00.0: unsupported HTC service id: 1536

shows it is using the ath10k but there is an “unsupported HTC service id: 1536”

Any ideas on “unsupported HTC service id: 1536” ?

Issue solved !
Laptop was used at another location where there was WiFi. The ‘Available Networks’ showed a couple of 5ghz SSID’s. Tried connecting to one of them and it worked.

Checked the settings back here, and it seems the Access Point I have been using for over a year here, was set for Country code: US. The AP channel was 151, but as can be seen from the frequency listing above, the F30 laptop stops at channel 140.
Changed the AP channel to within the available channels and it connected. All good.

Previously the Laptop had F28 and was connecting to 5Ghz wifi daily on the same AP; moving to F30 seems to have modified the Country and/or channel allocation and restricted the number of channe

Closing.

2 Likes